Forum

Thread tagged as: Error

exif_read_data warning/error on jpg upload

I receive this error/warning when uploading a jpg in the assets manager.

Warning: exif_read_data(phpGAENR3): Illegal IFD size in /whatever/public_html/perch/core/lib/PerchImage.class.php on line 536

Perch: 3.0.13, PHP: 5.6.24, MySQL: mysqlnd 5.0.11-dev - 20120503 - $Id: 76b08b24596e12d4553bd41fc93cccd5bac2fe7a $, with PDO
Server OS: Linux, cgi-fcgi
Installed apps: content (3.0.13), assets (3.0.13), categories (3.0.13)
App runtimes: <?php $apps_list = [ ];
PERCH_LOGINPATH: /~/perch
PERCH_PATH: /home//public_html/perch
PERCH_CORE: /home//public_html/perch/core
PERCH_RESFILEPATH: /home//public_html/perch/resources
Image manipulation: GD Imagick
PHP limits: Max upload 10M, Max POST 12M, Memory: 128M, Total max file upload: 10M
F1: 3b606135b33e6a102526838f4152a807
Resource folder writeable: Yes
DOCUMENT_ROOT: /usr/local/apache/htdocs
HTTP_HOST: 67.23.254.89
REQUEST_URI: /~/perch/core/settings/diagnostics/
SCRIPT_NAME: /~/perch/core/settings/diagnostics/index.php
Vicki Watson

Vicki Watson 0 points

  • 5 months ago
Drew McLellan

Drew McLellan 2544 points
Perch Support

A specific JPEG or any JPEG?

Drew McLellan

Drew McLellan 2544 points
Perch Support

You can disable EXIF completely with this in your perch/config.php file:

define('PERCH_ENABLE_EXIF', false);

but that will mean that things like image orientation data aren't read, so any images will need to be rotated to the correct orientation before you upload them.

Also keywords in the metadata won't be imported into tags in Assets.

Okay, thanks. It was just one jpg so far.

Drew McLellan

Drew McLellan 2544 points
Perch Support

If it's just one JPEG then it could be a malformed file.