We are transitioning over to a new forum platform. Please post new issues there. Existing threads will be dealt with here unless you choose to move them over. Visit the new forum

Forum

Thread tagged as: Problem, Configuration

UI Language setting (Perch Control Panel) => I cannot switch the UI language of...

Dear all,

I freshly downloaded Perch 3.1.4 files and copied it on the target server and made the set-up successfully: a/ two roles created (1 primary admin, 1 editor) b/ regions from the target index.php well visible and editable c/ file 'de-de.txt' downloaded from https://github.com/PerchCMS/Perch2-UI-Translations/tree/master/lang d/ file de-de.txt uploaded into the folder /perch/core/lang on the target server

My problem now: In the Perch control panel the language de-de is offered (good!) in the user profil, but if I select it, save it, then log-out, renew the browser and log-in again, it still remains in english and does not switch to german (de-de) language UI.

What am I doing wrong? How can I switch Perch control panel UI to the german de-de language?

Thank you very much for your help and best regards, Ekke (Munich)

Ekkehart Friauf

Ekkehart Friauf 0 points

  • 7 months ago
Drew McLellan

Drew McLellan 2638 points
Perch Support

You should put your language files in

/perch/addons/lang

so that they don't get overwritten when you upload a new perch/core folder during update.

The second thing to understand is that there are two places that language can be selected.

  1. You can set it in the main Settings page. This is the default for the system. New users will get this language as their default.
  2. In each user's personal settings. This overrides the system default for this individual user.

Hi Drew, thank you for your answer and the instructions.

1/ I followed your advice (de-de.txt moved from /perch/core/lang and inserted to /perch/addons/lang) and created a new user with language set to de-de.

2/ Then log-off and login as the new user, but still language UI is english for the new user (and still for all other users despite their individual language settings to de-de, too).

Notes: A/ I checked the Settings/diagnostic information, which shows 2 warnings: A1/ Setup folder is present and should be deleted A2/ Memory limit is low. Memory use is limited to -9.5367431640625E-7M, which could cause problems manipulating large images. (Neither the RAM on my computer nor on the server nor the server HDD space is low. What could be the problem here?). B/ In the index.php of the web-server there are about 150 editable regions (perch_content) defined (and respectively listed and filled in Perch).

Should I check something else? Or is there a way to reinstall or reset Perch WITHOUT loosing the content allocated to regions already?

Thank you for your help! Best regards, Ekkehart

The "how-to" link to the PERCH DEBUG MODE explanations does not work (https://docs.grabaperch.com/development/how-do-i-debug-problems) "Not Found - The requested URL /development/how-do-i-debug-problems was not found on this server.".

Is it there an alternative available?

Thx and best, Ekkehart

Drew McLellan

Drew McLellan 2638 points
Perch Support

Yes, it's here: https://docs.grabaperch.com/perch/building/troubleshooting/how-do-i-debug-problems/

I found it by typing debug into the search in the docs - it was the top result.

<Status report (no action)>

Yes, thank you, this helped. I switched on the debug mode now. (Not searching in the docs to find it was stupid by me, sorry, I will improve ... :) )

Now indeed, the debug mode throws an error á la "Unable to load language file: de-de" after stating the action status "Reloading language data". I tried it with more languages (fr-fr, nl-nl), but the same problem occurs, too.

I try to reproduce it with another perch instance, let's see. <Status report (no action)>

Drew McLellan

Drew McLellan 2638 points
Perch Support

You may want to run your JSON file through a validator to make sure it doesn't contain errors.

Yeah, your hint to validate the de-de json file helped! Unexpectedly the de-de.txt json-file does have a duplicate entry, which caused Perch not to load the de-de language (or any other language file even if the others were correct !).

Thanks a lot! I will upload the corrected de-de json file on a later date to Github.

Best, Ekkehart