We are transitioning over to a new forum platform. Please post new issues there. Existing threads will be dealt with here unless you choose to move them over. Visit the new forum

Forum

Thread tagged as: Question, Problem, Forms

Form Radio buttons - Return "on"

I have just updated to Perch 2.8.24 and my forms now return the word "on" for Radio buttons. I notice that .24 provided a fix for radio buttons and wasn't sure if this was my error or a bug.

Perch: 2.8.24, PHP: 5.6.15, MySQL: mysqlnd 5.0.11-dev - 20120503 - $Id: 3c688b6bbc30d36af3ac34fdd4b7b5b787fe5555 $, with PDO
Server OS: Linux, cgi-fcgi
Installed apps: content (2.8.24), assets (2.8.24), categories (2.8.24), perch_blog (5.0), perch_forms (1.8.3), perch_gallery (2.8.6), perch_mailchimp (2.0.1)
App runtimes: <?php include(PERCH_PATH.'/core/apps/content/runtime.php'); include(PERCH_PATH.'/addons/apps/perch_blog/runtime.php'); include(PERCH_PATH.'/addons/apps/perch_forms/runtime.php'); include(PERCH_PATH.'/addons/apps/perch_gallery/runtime.php'); include(PERCH_PATH.'/addons/apps/perch_mailchimp/runtime.php'); ?>
PERCH_LOGINPATH: /perch
PERCH_PATH: /homepages/35/d509465888/htdocs/perch
PERCH_CORE: /homepages/35/d509465888/htdocs/perch/core
PERCH_RESFILEPATH: /homepages/35/d509465888/htdocs/perch/resources
Image manipulation: GD
PHP limits: Max upload 40M, Max POST 8M, Memory: 120M, Total max file upload: 8M
F1: dc1fef2ad0fcd9f943c02ebb43d85dbc
Resource folder writeable: Yes
HTTP_HOST: www.thebristolcampercompany.co.uk
DOCUMENT_ROOT: /kunden/homepages/35/d509465888/htdocs
REQUEST_URI: /perch/core/settings/diagnostics/
SCRIPT_NAME: /perch/core/settings/diagnostics/index.php

This is my Form code:

<!--Awning required?-->
<div class="form-group">
  <perch:label for="Awning">Awning required?</perch:label>
<perch:input type="radio" id="Awning" class="extras" label="Awning required?" wrap="div.radiobutton" options="Yes, No" />
</div>
<!--Bike Rack?-->
<div class="form-group">
<perch:label for="bike">Bike rack required?</perch:label>
<perch:input type="radio" id="bike" class="extras" label="Bike rack?" options="Yes, No" wrap="div.radiobutton"/>
</div>

This is the live page:

The Bristol Camper Company

James Tedder

James Tedder 0 points

  • 4 years ago
Drew McLellan

Drew McLellan 2638 points
Perch Support

I think there's still maybe some buggy behaviour that we're looking into.

Thanks

Apologies for jumping on this thread, but I'm experiencing an identical problem and wondered whether there had been any progress with this buggy behaviour and whether there was a solution for getting around this?

I believe it has just been resolved in the latest release 2.8.25 - although I haven't updated it myself yet.

Thanks James, I'll look into it.

Morning all,

I was also experiencing this issue and I've updated on my local test environment to 2.8.25 and now the form is not sending or storing any responses.

Has maybe 2.8.25 broken something else?

I"ve not yet updated to this later version as yet and given your experience, may hold off. I'm not sure if anyone else can assist with this but I'll let you know if I resolve it.

Rachel Andrew

Rachel Andrew 394 points
Perch Support

A reminder! Even if you think you have the exact same issue as someone else please start your own thread including your template and Diagnostics Report. You can always link to the thread you think is the same issue if you think it is helpful.

It's very hard for us to help multiple people in one thread plus more often than not two people with what appears to be the same issue won't actually have the same issue, making that assumption can mean we head off down the wrong path in trying to help.

Also it's easy for us to miss a new response to an old thread we've closed, and we don't want to accidentally ignore people.

No problem!

Drew McLellan

Drew McLellan 2638 points
Perch Support

There are no known problems with forms in 2.8.25.