We are transitioning over to a new forum platform. Please post new issues there. Existing threads will be dealt with here unless you choose to move them over. Visit the new forum

Forum

Thread tagged as: Problem, Error, Configuration

Blank Page on Blog Post Create

Had this working before but might have got broken after an update as not used for a while.

Either editing an existing page or creating new goes to a blank page on save.

This is is error log: Call to a member function return_instance() on a non-object in /var/www/vhosts/stratfordhousedentalpractice.co.uk/httpdocs/admin/core/lib/api/PerchAPI_Form.class.php on line 415, referer: http://www.stratfordhousedentalpractice.co.uk/admin/addons/apps/perch_blog/edit/

Perch: 2.8.4, PHP: 5.4.38, MySQL: 5.1.59, with PDO Installed apps: content (2.8.4), assets (2.8.4), categories (2.8.4), perch_forms (1.8.3), perch_blog (4.5.4), perch_backup (1.2)

Nigel Coath

Nigel Coath 1 points

  • 4 years ago
Rachel Andrew

Rachel Andrew 394 points
Perch Support

Blog is out of date. You need to update your apps when you update Perch.

Turns out the issue was due to incomplete upload of the core folder, I used a different FTP software to transfer the files again. But I also updated the Blog app anyway!

Rachel Andrew

Rachel Andrew 394 points
Perch Support

The latest version of Perch requires the new Blog app as we made changes for Blocks.

Thats fine as updated anyway, but I think the main issue was a bad transfer.

Maybe I missed it but if not maybe perch update releases that require app updates as well should say so in the update notes?