We are transitioning over to a new forum platform. Please post new issues there. Existing threads will be dealt with here unless you choose to move them over. Visit the new forum

Forum

Thread tagged as: Problem, Runway, Blog

Runway Blog Post Page errors

Hi I have set up a Runway Blog (my first time) and have followed docs and also the helpful Perch Runway Blog video on YouTube. However, when viewing singles post pages, I am getting a blank page with these errors:

Warning: include(/Users/simonclay/Dropbox/Clients/Lowe Build/Lowe Build Website/New Lowe Build Website/perch/templates/pages/errors/404.php): failed to open stream: No such file or directory in /Users/simonclay/Dropbox/Clients/Lowe Build/Lowe Build Website/New Lowe Build Website/perch/core/runway/start.php on line 32

Warning: include(): Failed opening '/Users/simonclay/Dropbox/Clients/Lowe Build/Lowe Build Website/New Lowe Build Website/perch/templates/pages/errors/404.php' for inclusion (include_path='.:/Applications/MAMP/bin/php/php5.6.28/lib/php') in /Users/simonclay/Dropbox/Clients/Lowe Build/Lowe Build Website/New Lowe Build Website/perch/core/runway/start.php on line 32

The url in the address bar is correct, eg. http://lowebuild:8888/news/2017-03-31-news-post-1 My blog url is 'news' rather than blog, but I don't think that should be an issue.

My Diagnostics:

Perch is out of date. You are running Perch Runway 2.8.34 and the latest is 3.0.0. Update instructions
PHP 5.6.28 is up to date
MySQL 5.6.34 is up to date
Image processing available
SUMMARY INFORMATION

Perch Runway: 2.8.34, PHP: 5.6.28, MySQL: mysqlnd 5.0.11-dev - 20120503 - $Id: 76b08b24596e12d4553bd41fc93cccd5bac2fe7a $, with PDO
Server OS: Darwin, apache2handler
Installed apps: content (2.8.34), assets (2.8.34), categories (2.8.34), perch_forms (1.8.3), perch_blog (5.0)
App runtimes: <?php $apps_list = array( 'content', 'categories', 'perch_blog', 'perch_forms', );
PERCH_LOGINPATH: /perch
PERCH_PATH: /Users/simonclay/Dropbox/Clients/Lowe Build/Lowe Build Website/New Lowe Build Website/perch
PERCH_CORE: /Users/simonclay/Dropbox/Clients/Lowe Build/Lowe Build Website/New Lowe Build Website/perch/core
PERCH_RESFILEPATH: /Users/simonclay/Dropbox/Clients/Lowe Build/Lowe Build Website/New Lowe Build Website/perch/resources
Image manipulation: GD
PHP limits: Max upload 32M, Max POST 32M, Memory: 128M, Total max file upload: 32M
F1: 6a33f95eca3667f9e0c39bf5ca2980fe
Resource folder writeable: Yes
HTTP_HOST: lowebuild:8888
DOCUMENT_ROOT: /Users/simonclay/Dropbox/Clients/Lowe Build/Lowe Build Website/New Lowe Build Website
REQUEST_URI: /perch/core/settings/diagnostics/
SCRIPT_NAME: /perch/core/settings/diagnostics/index.php
Simon Clay

Simon Clay 127 points

  • 2 years ago
Drew McLellan

Drew McLellan 2638 points
Perch Support

Does your 404 master page exist?

Rachel Andrew

Rachel Andrew 394 points
Perch Support

the blog video on YouTube is for Perch not Runway, and also for Perch 3 if you are talking about the recent video.

If you are using Runway you need to make sure your routes are correct.

Simon Clay

Simon Clay 127 points

Thanks, the YouTube videos is Setting up a Blog in Perch Runway https://www.youtube.com/watch?v=wrJ20AvZt5o and it's very helpful.

I haven't set up 404 page yet.

I seem to have resolved it, but I don't understand how. My page path and URL pattern were: Page Path /news/post URL Pattern /news/[blogslug:s]

I added a trailing slash to the page path and it worked. /news/post/.

I then thought, 'hey, Perch set that page path automatically, without the trailing slash, so I shouldn't need to do that. So I removed it, and it still works.

I notice my URL Pattern has a slash before, whereas in your demo Drew, you don't seem to put the root slash in there. But it hasn't made a difference.

Still it works now, but I'm unsure as to why.

Simon Clay

Simon Clay 127 points

Hi, sorry to resurrect this thread again, but I am having the same problem.

I have set up a News section in Runway and have the News listing working at /news

However, when I click on a news item in the listing, I get the 404 page.

The url in the address bar is correct, e.g: http://lowesips:8888/news/2017-04-08-rugby-club-sips-extension-update-april-2017 My Post page location path is /news/post My Route URL pattern is: news/[blogslug:s]

Can you help with how to resolve the issue please?

Drew McLellan

Drew McLellan 2638 points
Perch Support

Is blogslug a token you've configured?

Simon Clay

Simon Clay 127 points

Yes, as per the helpful video I added to perch/config/runway.php:

'routing_tokens' => [
            'blogslug' => '[1-2][0-9]{3}\-[0-9]{2}\-[0-3][0-9]-[a-z0-9\-]+',
        ],
Drew McLellan

Drew McLellan 2638 points
Perch Support

Have you saved your routes since adding that? If it wasn't in place when the route was created it won't have compiled.