We are transitioning over to a new forum platform. Please post new issues there. Existing threads will be dealt with here unless you choose to move them over. Visit the new forum

Forum

Thread tagged as: Problem

License key isn't valid if running PHP 7.1.17

I am getting the message: 'Sorry, your license key isn't valid for this domain.' But if I roll the PHP version back to 7.0.30 it lets me in.

PHP 7.0.30 is up to date
MySQL 5.5.56-MariaDB is up to date
Image processing available
SUMMARY INFORMATION

Perch: 2.8.31, PHP: 7.0.30, MySQL: mysqlnd 5.0.12-dev - 20150407 - $Id: b5c5906d452ec590732a93b051f3827e02749b83 $, with PDO
Server OS: Linux, fpm-fcgi
Installed apps: content (2.8.31), assets (2.8.31), categories (2.8.31), perch_blog (5.0), perch_forms (1.8.3)
App runtimes: <?php $apps_list = array( 'content', 'categories', 'perch_forms', 'perch_blog', );
PERCH_LOGINPATH: /perch
PERCH_PATH: /var/www/vhosts/vqsltd.co.uk/httpdocs/perch
PERCH_CORE: /var/www/vhosts/vqsltd.co.uk/httpdocs/perch/core
PERCH_RESFILEPATH: /var/www/vhosts/vqsltd.co.uk/httpdocs/perch/resources
Image manipulation: GD Imagick
PHP limits: Max upload 8M, Max POST 16M, Memory: 128M, Total max file upload: 8M
F1: 2edba60ed1f613d6dd804feb202456a2
Resource folder writeable: Yes
SCRIPT_NAME: /perch/core/settings/diagnostics/index.php
REQUEST_URI: /perch/core/settings/diagnostics/
DOCUMENT_ROOT: /var/www/vhosts/vqsltd.co.uk/httpdocs
HTTP_HOST: www.vqsltd.co.uk
Simon Clay

Simon Clay 127 points

  • 1 year ago
Duncan Revell

Duncan Revell 78 points
Registered Developer

Hi Simon,

You need to be up to 2.8.34 to sort that - some fixes for PHP 7.1 were introduced on or around that version.