We are transitioning over to a new forum platform. Please post new issues there. Existing threads will be dealt with here unless you choose to move them over. Visit the new forum

Forum

Thread tagged as: Question, Addons, Shop

Tried keying in the path rather than clicking and same result. I'm going to upload it to a testing server to make sure its not MAMP Pro.

Drew McLellan

Drew McLellan 2638 points
Perch Support

Ok, it sounds like perhaps it's not the menu at all. What privileges do you have set? Do the Shop privileges appear in the list?

Uploaded to testing server, same results.

Regarding the roles, under admin, there is nothing about shop, just usual content and blog

Drew McLellan

Drew McLellan 2638 points
Perch Support

Did you have any version of a Shop app installed previously?

No, went straight to v1.2... is that the problem. Should I try installing v1 first?

Drew McLellan

Drew McLellan 2638 points
Perch Support

No, I'm just trying to understand why you don't have a complete install.

Hi Drew

I've tried again and missed out the upgrade to Perchv3 this time and added shopv1.0.12 and samw result, but I do get the Shop and Members option in the roles.

SUMMARY INFORMATION

Perch: 2.8.34, PHP: 5.6.30, MySQL: mysqlnd 5.0.11-dev - 20120503 - $Id: 76b08b24596e12d4553bd41fc93cccd5bac2fe7a $, with PDO
Server OS: Darwin, cgi-fcgi
Installed apps: content (2.8.34), assets (2.8.34), categories (2.8.34), perch_blog (4.6), perch_shop_orders (1.0.12), perch_shop_products (1.0.12), perch_shop (1.0.12), perch_members (1.5)
App runtimes: <?php $apps_list = array( 'content', 'categories', 'perch_blog', );
PERCH_LOGINPATH: /perch
PERCH_PATH: /Users/hoops78/Documents/the beauty room/perch
PERCH_CORE: /Users/hoops78/Documents/the beauty room/perch/core
PERCH_RESFILEPATH: /Users/hoops78/Documents/the beauty room/perch/resources
Image manipulation: GD
PHP limits: Max upload 32M, Max POST 32M, Memory: 128M, Total max file upload: 32M
F1: 6a33f95eca3667f9e0c39bf5ca2980fe
Resource folder writeable: Yes
SCRIPT_NAME: /perch/core/settings/diagnostics/index.php
REQUEST_URI: /perch/core/settings/diagnostics/
DOCUMENT_ROOT: /Users/hoops78/Documents/the beauty room
HTTP_HOST: beautyroom
Drew McLellan

Drew McLellan 2638 points
Perch Support

All I can think is this is something to do with your server. If it's happening with Perch 2, it very unlikely that a problem would've existed all that time without anyone else seeing it.

Thanks Drew

I'll try and install on a dev server we've got. I upgraded mamp pro recently so maybe I'm missing a setting I used to have.

Regards Wayne

It must of been something in my MAMP that was stopping the shop installing fully as I've now uploaded a version to a testing server and its installed fine.

Thanks for your help.

Wayne