We are transitioning over to a new forum platform. Please post new issues there. Existing threads will be dealt with here unless you choose to move them over. Visit the new forum

Forum

Thread tagged as: Problem, Error

Can't add page, get Forbidden on form submit

On an established site trying to add a page (just a link, actually) on the Add a New Page screen and upon Submit there is a 403 Forbidden error. Strange, because the URL of the page is the same as the Add a New Page form, which displayed fine, just adding a query string.

Updated to 2.8.6 but still get the same result.

/admin/core/apps/content/page/add/ has 644 permissions and the same owner as every other page.

Brain fried. Not sure what else to try.

Kirk Roberts

Kirk Roberts 0 points

  • 4 years ago
Drew McLellan

Drew McLellan 2637 points
Perch Support

What sort of environment is this in?

HOSTING SETTINGS

PHP: 5.4.40
Zend: 2.4.0
OS: Linux
SAPI: cgi-fcgi
Safe mode: not detected
MySQL client: mysqlnd 5.0.10 - 20111026 - $Id: c85105d7c6f7d70d609bb4c000257868a40840ab $
MySQL server: 5.1.73-cll
Extensions: Core, date, ereg, libxml, openssl, pcre, sqlite3, zlib, bcmath, calendar, ctype, curl, dom, hash, filter, ftp, gd, SPL, iconv, session, json, mbstring, mcrypt, standard, mysql, mysqli, mysqlnd, Phar, posix, pspell, Reflection, imap, SimpleXML, soap, sockets, exif, tokenizer, xml, xmlreader, xmlrpc, xmlwriter, xsl, zip, cgi-fcgi, PDO, pdo_sqlite, timezonedb, pdo_mysql, ionCube Loader, Zend Guard Loader
GD: Yes
ImageMagick: No
PHP max upload size: 30M
PHP max form post size: 30M
PHP memory limit: 180M
Total max uploadable file size: 30M
Resource folder writeable: Yes
Session timeout: 24 minutes
Native JSON: Yes
Filter functions: Yes
Transliteration functions: No
Drew McLellan

Drew McLellan 2637 points
Perch Support

Is this local, or a hosting server? Do you have any unusually restrictive configuration?

It's a hosting server, and it's a garden variety shared hosting plan. I've put quite a few Perch sites on the same host, and the site in question has been in service with Perch for over a year. Something must have changed on the server, but I'm at a loss as to what to investigate or try next. It's especially vexing that the "add page" Perch form would load fine with no data, but then show a 403 Forbidden error on save. Isn't is the exact same file that's reloading on Submit?

Drew McLellan

Drew McLellan 2637 points
Perch Support

The difference is the HTTP GET vs POST.

Does the page have a lot of content, or anything in the content that might look suspicious or spammy?

It's the standard Perch "add a page" form in the control panel. /admin/core/apps/content/page/add/

Trying to add a "link only" page with title "Ultimate Plant-Based Nutrition Resource Guide" and url "https://resources.plantricianproject.org"

Drew McLellan

Drew McLellan 2637 points
Perch Support

I think you'll need to speak to your host. It sounds like strangely configured mod_security rules.

Okay, thanks, I wouldn't have thought of that. It does seem a little spammy :-) I'll ask the host.