We are transitioning over to a new forum platform. Please post new issues there. Existing threads will be dealt with here unless you choose to move them over. Visit the new forum

Forum

Thread tagged as: Question, Problem, Installation

Login problems

Hi, I'm having problems loging in to Perch on my local (Wampp) server.

I have tested PHP with Wamp and it seems to work fine. I have tried to use perch on a website locally and get the familiar error below:

I can’t login

You try to log into Perch and are immediately bounced back to the login page with a query string that looks like ?r=%2Fperch%2Fcore%2Fapps%2Fcontent%2F.

This usually means a problem with Sessions on your server. Either you need to enable PHP Sessions in some way, or if this was previously working it may be that your Sessions folder is full. Either way this is something you will need to speak to you host about.

I have followed various online guides to setting sessions in Wamp but the problem persists.

Is there anyone out there who might be able to help me?

Cheers - Mark

mark buckley

mark buckley 0 points

  • 1 year ago
Rachel Andrew

Rachel Andrew 394 points
Perch Support

I would suggest posting in the Wamp forums for help, as this isn't Perch specific you just need to know how to enable sessions.

Thanks Rachel. However, I have got nowhere there and figured that you are likely to have some users who use windows and wamp and might be able to help.

It's very annoying as it works with everything else I do, just wont let me sign in to Perch.

So, if there's anyone out there...

Cheers - Mark

Simon Clay

Simon Clay 127 points

Hi Mark,

Some other threads have mentioned solutions that work for some:

Force Update

By visiting /perch/core/update

Remove any old Core folders

As mentioned at the bottom of this thread http://forum.grabaperch.com/forum/02-27-2016-2826-upgrade-stuck-at-repeating-login

Check your error log and check that PHP sessions are working

Upgrade or downgrade to a newer or older version of Perch

http://forum.grabaperch.com/forum/01-24-2018-cannot-login-after-update-to-2834?page=1#reply-56820

Hi Shane

What I saw when I had the problem is as described above.

The update to 3.1.2 fixed the issue for me.

Cheers - Mark