We are transitioning over to a new forum platform. Please post new issues there. Existing threads will be dealt with here unless you choose to move them over. Visit the new forum

Forum

Thread tagged as: Forms, Problem, Addons

Perch form won't send to my email

I have tested this with a different email and it sends fine but it wont send to my hosted email account. I also tested the email in the settings area.

<perch:form id="contact-page-form" method="post" app="perch_forms">

    <div class="col-md-4">
        <perch:input type="text" id="name" required="true" label="Name" />
        <perch:error for="name-2" type="required">Please add your name</perch:error>
        <perch:label for="name-2">Name</perch:label>

        <perch:input type="email" id="email" required="true" label="Email" />
        <perch:error for="email-2" type="required">Please add your email address</perch:error>
        <perch:error for="email-2" type="format">Please check your email address</perch:error>
        <perch:label for="email-2">Email</perch:label>

        <perch:input type="text" id="phone-2" required="true" label="Phone" />
        <perch:error for="phone-2" type="required">Please add your phone number</perch:error>
        <perch:label for="phone-2">Phone</perch:label>
    </div>

    <div class="col-md-7">
        <perch:input type="textarea" id="message-2" required="true" label="Message" />
        <perch:error for="message-2" type="required">Please add a message</perch:error>
        <perch:label for="message-2">Message</perch:label>
    </div>


    <div class="main-button-2"> 
        <perch:input type="submit" id="submit" value="Send message" />
    </div>


</perch:form>

<div id="thanks-contact" class="row">
    <div class="col-md-12">
        <h1>Thanks for getting in touch you will hear from us shortly.</h1>
    </div>
</div>

</div>
David Henderson

David Henderson 0 points

  • 6 years ago
Drew McLellan

Drew McLellan 2638 points
Perch Support

If your server will send to a different address, it's more likely that the email isn't being received, rather than it not being sent.

Have you tested the address using the tool under Settings?

Hi Drew thank you for the replay I just fixed it. It didn't like the send from email being the same as the send to.