We are transitioning over to a new forum platform. Please post new issues there. Existing threads will be dealt with here unless you choose to move them over. Visit the new forum

Forum

Thread tagged as: Problem, CKEditor

Ckeditor not loading for blocks

Just want to note that I've been having the exact same issue as http://forum.grabaperch.com/forum/05-14-2017-perch-3-ckeditor-not-loading-for-blocks

I'm using Perch 3.0.8 -

Using blocks. When I create a new block, the editor doesn't show initially. As the previous thread mentions once you save the editor appears. But it is a bit annoying and probably confusing to the client who may not remember they need to save first to format the text.

Diagnostics Report

Perch Runway: 3.0.8, PHP: 5.6.30, MySQL: mysqlnd 5.0.11-dev - 20120503 - $Id: 76b08b24596e12d4553bd41fc93cccd5bac2fe7a $, with PDO
Server OS: Linux, fpm-fcgi
Installed apps: content (3.0.8), assets (3.0.8), categories (3.0.8), perch_blog (5.5.1), perch_forms (1.9), perch_shop_orders (1.2.2), perch_shop_products (1.2.2), perch_shop (1.2.2), perch_members (1.6.2)
App runtimes: <?php $apps_list = [ 'content', 'categories', 'perch_blog', 'perch_forms', 'perch_members', 'perch_shop', ];
PERCH_LOGINPATH: /perch
PERCH_PATH: /chroot/home/wgw/dev.wineglasswriter.com/html/perch
PERCH_CORE: /chroot/home/wgw/dev.wineglasswriter.com/html/perch/core
PERCH_RESFILEPATH: /chroot/home/wgw/dev.wineglasswriter.com/html/perch/resources
Image manipulation: GD
PHP limits: Max upload 50M, Max POST 50M, Memory: 128M, Total max file upload: 50M
F1: 0c66c2e1f82f9e0b7617b2cb8270f2c7
Resource folder writeable: Yes
HTTP_HOST: dev.wineglasswriter.com
DOCUMENT_ROOT: /home/wgw/dev.wineglasswriter.com/html
REQUEST_URI: /perch/core/settings/diagnostics/
SCRIPT_NAME: /perch/core/settings/diagnostics/index.php
Herman Steuernagel

Herman Steuernagel 0 points

  • 2 years ago
Drew McLellan

Drew McLellan 2638 points
Perch Support

Is your CKEditor plugin up to date? This is something I thought we'd fixed.

Sorry my mistake - it does look like I was using an older version.

Thank you.