We are transitioning over to a new forum platform. Please post new issues there. Existing threads will be dealt with here unless you choose to move them over. Visit the new forum

Forum

Thread tagged as: Problem, Installation, Runway

New install Runway Developers version - Cron Job throwing errors

I installed a Developers version of Runway yesterday on an A2 Hosting Turbo Shared hosting account and I scheduled the Cron Job as instructed in the installation instructions and now each hour I am receiving the following error message from the Cron Job. Please advise where I have gone wrong? What should I do?

X-Powered-By: PHP/5.3.29 Content-type: text/html

<br /> <b>Parse error</b>: syntax error, unexpected '[' in <b>/home/sbsportf/public_html/perch/core/runway/lib/PerchRouter.class.php</b> on line <b>8</b><br />

Here is the command I entered in Cron

php /home/sbsportf/public_html/perch/core/scheduled/run.php rhTsvWHaXEDgnCdd

Sue Stewart

Sue Stewart 0 points

  • 4 years ago
Drew McLellan

Drew McLellan 2638 points
Perch Support

X-Powered-By: PHP/5.3.29

Runway requires at least PHP 5.4

My Perch Runway install is reporting the following:

Perch Runway: 2.8.8, PHP: 5.5.25, MySQL: 5.5.34, with PDO

So my guess is the server where the Cron jobs are run needs a newer version of PHP. Do you think if the hosting company updates the server running the Cron jobs it will take care of this problem?

Sue

Drew McLellan

Drew McLellan 2638 points
Perch Support

The PHP binary used for cron is different from the one used by the web server. It's known as PHP CLI (command line interface).

You need to ask your host how to change the PHP CLI version to at least 5.4.