We are transitioning over to a new forum platform. Please post new issues there. Existing threads will be dealt with here unless you choose to move them over. Visit the new forum

Forum

Thread tagged as: Problem, Installation, Addons

Perch UI translations only work on the login page

Hello,

I'm working on a translation, and run into a problem when wanted to switch the Perch UI language from English to a custom one. I've used de-de.txt for testing from the Perch2-UI-Translations repository on GitHub (but the problem applies to all language files I've tried so far too).

Here are the steps I've done (let me know if I did it wrong):
1. I've downloaded de-de.txt from GitHub.
2. I've put de-de.txt into folder /perch/addons/lang (as a forum post suggested to do so).
3. I've selected de-de.txt in Perch's language settings dropdown (de-de appeared as it should, so that I could select it).
4. After saving the changes, nothing changed on the UI, everything was English, as before – with exactly the same strings.
5. After logging out, and refreshing the login page the Deutsch translation appeared correctly. After signing in, English language was displayed again though de-de was still active in language settings. Refreshing the pages within the admin didn't help either – only on the login page.

What am I doing wrong? How can I make the chosen language take effect everywhere on the UI?

Note, that I've also tried creating a new language file by duplicating and slightly modifying the original Perch version 3 en-gb.txt for a test, but the same happened – so that using language files originally created for Perch version 2 or 3 doesn't have an impact on the above.

Thanks in advance!

Márton Lente

Márton Lente 0 points

  • 2 years ago
Drew McLellan

Drew McLellan 2638 points
Perch Support

There are two language settings, one default for the entire site and one for each specific user. Have you set your user language preference?

Hello Drew,

Thank you for your tip – this was it, it solved the problem! :)

Another thing I forgot to ask is, do I have to place custom language files only to the referenced /perch/addons/lang folder? I've discovered there is another language folder within Perch at /perch/core/lang. Should I leave the latter folder 'untouched'? Custom languages actually work with the above folder only, just want to make sure I'm doing it 'right'.

Thank you!