We are transitioning over to a new forum platform. Please post new issues there. Existing threads will be dealt with here unless you choose to move them over. Visit the new forum

Forum

Thread tagged as: Problem, Error

Unable to load assets and asset organize page is blank

Recently the ability to upload assets has stopped functioning on one of my sites. When I click "Select or upload an image", the pop-up "Select an Asset" panel shows with all assets that have previously been uploaded, but the buttons for "Add asset" and "Use selected" aren't functional -- clicking them does nothing.

In addition when I go the Organize > Assets page, no assets appear.

When I'm in the entry page I get two console errors in the browser:

[Error] Failed to load resource: the server responded with a status of 500 (Internal Server Error) (asset-filter, line 0)
[Error] Failed to load resource: the server responded with a status of 500 (Internal Server Error) (asset-filter, line 0)

My diagnostic information is below:

Viewing diagnostic information

Perch Runway: 3.1.2, PHP: 7.0.30, MySQL: mysqlnd 5.0.12-dev - 20150407 - $Id: b5c5906d452ec590732a93b051f3827e02749b83 $, with PDO
Server OS: Linux, cgi-fcgi
Installed apps: content (3.1.2), assets (3.1.2), categories (3.1.2), perch_blog (5.6.1), perch_varnish (1.0), pipit_sharing (1.2.0)
App runtimes: <?php $apps_list = array( 'perch_blog', 'pipit_sharing', 'categories', ); ?>
PERCH_LOGINPATH: /perch
PERCH_PATH: /home/tswan/oviahealth.com/perch
PERCH_CORE: /home/tswan/oviahealth.com/perch/core
PERCH_RESFILEPATH: /home/tswan/oviahealth.com/perch/resources
Image manipulation: GD Imagick
PHP limits: Max upload 64M, Max POST 65M, Memory: 90M, Total max file upload: 64M
F1: 3b606135b33e6a102526838f4152a807
Resource folder writeable: Yes
SCRIPT_NAME: /perch/core/settings/diagnostics/index.php
REQUEST_URI: /perch/core/settings/diagnostics/
DOCUMENT_ROOT: /home/tswan/oviahealth.com
HTTP_HOST: www.oviahealth.dreamhosters.com

When I turn on debug for an entry page, I get:

Debug Message - Perch Runway 3.1.1
[1]
SELECT u.*, r.* FROM perch3_users u, perch3_user_roles r WHERE u.roleID=r.roleID AND u.userEnabled=1 AND u.userID=1 AND u.userHash='7e1dd31ff47501ba6c3e4d8d0311013c' LIMIT 1
UPDATE perch3_users SET userHash='e8f7bbed2b9a9e7ed59c6ba7ca70fd0a' WHERE userID='1'
[34]
SELECT settingID, settingValue, userID FROM perch3_settings WHERE userID=1 OR userID=0 ORDER BY userID ASC
Adding: Varnish
Varnish enavled!
Adding: Pipit Sharing
[12]
SELECT itemValue FROM perch3_menu_items WHERE itemType='app'
[0]
SELECT COUNT(*) FROM perch3_blog_comments WHERE commentStatus='PENDING'
[1]
SELECT * FROM perch3_blog_authors WHERE authorEmail='timswan@gmail.com' LIMIT 1
[1]
SELECT * FROM perch3_blog_posts WHERE postID=296
[1]
SELECT * FROM perch3_blog_sections ORDER BY sectionTitle ASC
[3]
SELECT * FROM perch3_blogs ORDER BY blogTitle ASC
[1]
SELECT * FROM perch3_blogs WHERE blogID=1 LIMIT 1
[1]
SELECT * FROM perch3_blog_sections WHERE blogID='1' ORDER BY sectionTitle ASC
Using template: /templates/blog/post.html
Using sub-template: /templates/content/blocks/blog/text_block.html
Using sub-template: /templates/content/blocks/blog/text-over-3-links.html
Using sub-template: /templates/content/blocks/blog/pullquote.html
Using sub-template: /templates/content/blocks/blog/full-width-image.html
Edit mode: edit
[1]
SELECT mi.*, p.privKey FROM perch3_menu_items mi LEFT JOIN perch3_user_privileges p ON mi.privID=p.privID WHERE mi.itemActive=1 AND mi.parentID=0 ORDER BY itemOrder ASC LIMIT 0, 1
[5]
SELECT mi.*, p.privKey FROM perch3_menu_items mi LEFT JOIN perch3_user_privileges p ON mi.privID=p.privID WHERE mi.itemActive=1 AND mi.parentID=1 ORDER BY mi.itemOrder ASC
[1]
SELECT itemTitle FROM perch3_menu_items WHERE itemType='app' AND itemValue='perch_blog' LIMIT 1
[1]
SELECT mi.*, p.privKey FROM perch3_menu_items mi LEFT JOIN perch3_user_privileges p ON mi.privID=p.privID WHERE mi.itemActive=1 AND mi.parentID=0 ORDER BY itemOrder ASC LIMIT 1, 10
[2]
SELECT mi.*, p.privKey FROM perch3_menu_items mi LEFT JOIN perch3_user_privileges p ON mi.privID=p.privID WHERE mi.itemActive=1 AND mi.parentID=2 ORDER BY mi.itemOrder ASC
File: /addons/apps/perch_blog/modes/edit.post.php
[8]
SELECT * FROM perch3_categories c, perch3_category_sets s WHERE c.setID=s.setID AND s.setSlug='blog' ORDER BY catTreePosition ASC
[1]
SELECT * FROM perch3_categories WHERE catID=10 LIMIT 1
Queries: 19
Memory: 1.2143

Any idea what could be causing this?

Thanks, Tim

Timothy Swan

Timothy Swan 0 points

  • 1 year ago
Drew McLellan

Drew McLellan 2638 points
Perch Support

Have you checked your error log for the entry that corresponds to the 500 status?

Yes, in my error log it says:

[Mon Aug 13 06:13:11 2018] [warn] [client 76.28.34.243] mod_fcgid: stderr: Handler not found: backup, referer: http://www.mydomain.com/perch/core/apps/content/edit/?id=191
[Mon Aug 13 06:13:11 2018] [warn] [client 76.28.34.243] mod_fcgid: stderr: PHP Fatal error:  Uncaught Error: Call to a member function get_name() on null in /home/tswan/www.mydomain.com/perch/core/apps/assets/modes/_smart_bar.php:39, referer: http://www.mydomain.com/perch/core/apps/content/edit/?id=191
[Mon Aug 13 06:13:11 2018] [warn] [client 76.28.34.243] mod_fcgid: stderr: Stack trace:, referer: http://www.mydomain.com/perch/core/apps/content/edit/?id=191
[Mon Aug 13 06:13:11 2018] [warn] [client 76.28.34.243] mod_fcgid: stderr: #0 /home/tswan/www.mydomain.com/perch/core/apps/assets/async/asset-filter/index.php(39): include(), referer: http://www.mydomain.com/perch/core/apps/content/edit/?id=191
[Mon Aug 13 06:13:11 2018] [warn] [client 76.28.34.243] mod_fcgid: stderr: #1 {main}, referer: http://www.mydomain.com/perch/core/apps/content/edit/?id=191
[Mon Aug 13 06:13:11 2018] [warn] [client 76.28.34.243] mod_fcgid: stderr:   thrown in /home/tswan/www.mydomain.com/perch/core/apps/assets/modes/_smart_bar.php on line 39, referer: http://www.mydomain.com/perch/core/apps/content/edit/?id=191
Drew McLellan

Drew McLellan 2638 points
Perch Support

Do you have buckets defined in your buckets.php file?

I had a bucket set up for backups. I removed that and things are now working fine.

Thanks so much! Tim