We are transitioning over to a new forum platform. Please post new issues there. Existing threads will be dealt with here unless you choose to move them over. Visit the new forum

Forum

Thread tagged as: Error

Can't login - says need license but already have license for that domain

Hi,

The domain has been licensed for several years but today has raised an issue saying the license key is not valid.
Hi,

The domain has been licensed for several years but today has raised an issue saying the license key is not valid.

Warning: Illegal string offset 'key' in /home/dklein/public_html/perch/core/lib/PerchAuthenticatedUser.class.php on line 192 Warning: Illegal string offset 'host' in /home/dklein/public_html/perch/core/lib/PerchAuthenticatedUser.class.php on line 193 Warning: Illegal string offset 'version' in /home/dklein/public_html/perch/core/lib/PerchAuthenticatedUser.class.php on line 194 Warning: Illegal string offset 'php' in /home/dklein/public_html/perch/core/lib/PerchAuthenticatedUser.class.php on line 195 Warning: http_build_query(): Parameter 1 expected to be Array or Object. Incorrect value given in /home/dklein/public_html/perch/core/lib/PerchAuthenticatedUser.class.php on line 196 Warning: Cannot modify header information - headers already sent by (output started at /home/dklein/public_html/perch/core/lib/PerchAuthenticatedUser.class.php:192) in /home/dklein/public_html/perch/core/inc/auth.php on line 29 Warning: Cannot modify header information - headers already sent by (output started at /home/dklein/public_html/perch/core/lib/PerchAuthenticatedUser.class.php:192) in /home/dklein/public_html/perch/core/inc/auth.php on line 50 Warning: Cannot modify header information - headers already sent by (output started at /home/dklein/public_html/perch/core/lib/PerchAuthenticatedUser.class.php:192) in /home/dklein/public_html/perch/core/lib/PerchUtil.class.php on line 1212 Warning: Cannot modify header information - headers already sent by (output started at /home/dklein/public_html/perch/core/lib/PerchAuthenticatedUser.class.php:192) in /home/dklein/public_html/perch/core/lib/PerchUtil.class.php on line 1213 Warning: Cannot modify header information - headers already sent by (output started at /home/dklein/public_html/perch/core/lib/PerchAuthenticatedUser.class.php:192) in /home/dklein/public_html/perch/core/lib/PerchUtil.class.php on line 1214 Warning: Cannot modify header information - headers already sent by (output started at /home/dklein/public_html/perch/core/lib/PerchAuthenticatedUser.class.php:192) in /home/dklein/public_html/perch/core/lib/PerchUtil.class.php on line 1220 Warning: Cannot modify header information - headers already sent by (output started at /home/dklein/public_html/perch/core/lib/PerchAuthenticatedUser.class.php:192) in /home/dklein/public_html/perch/core/inc/top.php on line 17 Log in Username Kleinonline Password Sorry, your license key isn't valid for this domain. Log into your Perch account and add the followin g as your live or testing domain: kleinonline.co.uk 16/08/2018 Log in - Perch https://kleinonline.co.uk/perch/ LLoogg iinn or Reset password by edgeofmyseat.com

I am not aware of any changes to any files or permissions, please advise. Thanks Karen

Karen Blaylock

Karen Blaylock 0 points

  • 1 year ago
Rachel Andrew

Rachel Andrew 394 points
Perch Support

Has your server been upgraded to a new version of PHP? If so you need to upgrade Perch.

Hi,

I will check and let you know, thanks.

Hi Rachel,

The domain shows as PHP 7.1 - same as has been for quite a long time. Any further thoughts? Karen

Drew McLellan

Drew McLellan 2638 points
Perch Support

You need to upgrade Perch - the version you're running is too old for PHP 7.1

Hi,

Do I need to upgrade to Perch3 and the latest version?

Drew McLellan

Drew McLellan 2638 points
Perch Support

If you're currently on Perch 2 then the version you need is 2.8.34.

OK, thanks

Hi,

Do you have the instructions for updating to the latest version of Perch 2 please? I can onlyh see instructions for moving to Perch 3 thanks

Hi,

I have successfully updated the version and the problem has been resolved, thanks.