We are transitioning over to a new forum platform. Please post new issues there. Existing threads will be dealt with here unless you choose to move them over. Visit the new forum

Forum

Thread tagged as: Problem

No content yet?

Hi... I'm totally baffled with a issue I'm having with no content showing in the admin. No content yet?

I have tried everything i can think of and its still not working:

1) Removed all files and Re uploaded all files

2) Removed database and reinstalled perch

3) Contacted hosting company

4) Done the perch health check and everything is ok

Is there anything else i can do

Stephen Wild

Stephen Wild 3 points

  • 4 years ago
Perch: 2.8.11, PHP: 5.6.12, MySQL: mysqlnd 5.0.11-dev - 20120503 - $Id: 3c688b6bbc30d36af3ac34fdd4b7b5b787fe5555 $, with PDO
Server OS: Linux, cgi-fcgi
Installed apps: content (2.8.11), assets (2.8.11), categories (2.8.11), perch_forms (1.8.3)
App runtimes: <?php $apps_list = array( 'content', 'categories', 'perch_forms', );
PERCH_LOGINPATH: /admin
PERCH_PATH: /customers/5/1/8/mutzcutzandposes.co.uk/httpd.www/admin
PERCH_CORE: /customers/5/1/8/mutzcutzandposes.co.uk/httpd.www/admin/core
PERCH_RESFILEPATH: /customers/5/1/8/mutzcutzandposes.co.uk/httpd.www/admin/resources
Image manipulation: GD
PHP limits: Max upload 96M, Max POST 96M, Memory: 128M, Total max file upload: 96M
Resource folder writeable: Yes
SCRIPT_NAME: /admin/core/settings/diagnostics/index.php
REQUEST_URI: /admin/core/settings/diagnostics/
HTTP_HOST: www.mutzcutzandposes.co.uk
DOCUMENT_ROOT: /customers/5/1/8/mutzcutzandposes.co.uk/httpd.www
Drew McLellan

Drew McLellan 2638 points
Perch Support

What did you do before concluding there was a problem?

Should be something like:

  1. Add the Perch runtime to your page

  2. Add a region to your page like <?php perch_content('My region'); ?>

  3. Load your page in a browser

  4. Refresh the control panel to see your region.

Yep... done all that. I have over 50 licenses with you so I'm not a total numpty.

Drew McLellan

Drew McLellan 2638 points
Perch Support

If you add debug to the page with the regions, what does it output when you load it?

SELECT u.*, r.* FROM perch2_users u, perch2_user_roles r WHERE u.roleID=r.roleID AND u.userEnabled=1 AND u.userID=1 AND u.userHash='72c08ab99c5dcea606045486a02b5bf7' LIMIT 1
UPDATE perch2_users SET userHash='b675ab6c409d659819a3cee5b0cca6e7' WHERE userID='1'
SELECT p.privKey FROM perch2_user_privileges p
SELECT * FROM (SELECT DISTINCT settingID, settingValue FROM perch2_settings WHERE userID=1 OR userID=0 ORDER BY userID DESC) AS settings GROUP BY settingID
SELECT *, REPLACE(pagePath, '/index.php', '') as sortPath FROM perch2_pages WHERE pageNew=1 ORDER BY LENGTH(sortPath)-LENGTH(REPLACE(sortPath, '/', '')) ASC
SELECT p.*, (SELECT COUNT(*) FROM perch2_pages WHERE pageParentID=p.pageID) AS subpages FROM perch2_pages p WHERE p.pageParentID IN (0) ORDER BY p.pageTreePosition ASC
SELECT * FROM perch2_content_regions ORDER BY regionOrder ASC
SELECT * FROM perch2_content_regions WHERE regionPage='*'
SELECT DISTINCT regionTemplate FROM perch2_content_regions ORDER BY regionTemplate ASC

On the assets page I get this error

Invalid query: SQLSTATE[42S22]: Column not found: 1054 Unknown column 'r2.resourceWidth' in 'field list'
SELECT FOUND_ROWS() AS `count`
SELECT DISTINCT resourceType FROM perch2_resources WHERE resourceAWOL=0 AND resourceType !="" ORDER BY resourceType ASC
Invalid query: SQLSTATE[42S22]: Column not found: 1054 Unknown column 'resourceAWOL' in 'where clause'
SELECT DISTINCT resourceBucket FROM perch2_resources WHERE resourceAWOL=0 AND resourceType !="" ORDER BY resourceType ASC
Invalid query: SQLSTATE[42S22]: Column not found: 1054 Unknown column 'resourceAWOL' in 'where clause'

and on the categories page

SELECT u.*, r.* FROM perch2_users u, perch2_user_roles r WHERE u.roleID=r.roleID AND u.userEnabled=1 AND u.userID=1 AND u.userHash='8f5461bbafac795f8aa90762e726aab4' LIMIT 1
UPDATE perch2_users SET userHash='f0e06036df763bd5e7ea6a68e2ea8841' WHERE userID='1'
SELECT p.privKey FROM perch2_user_privileges p
SELECT * FROM (SELECT DISTINCT settingID, settingValue FROM perch2_settings WHERE userID=1 OR userID=0 ORDER BY userID DESC) AS settings GROUP BY settingID
SELECT SQL_CALC_FOUND_ROWS DISTINCT * FROM perch2_category_sets ORDER BY setTitle ASC LIMIT 0, 24
Invalid query: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'mutzcutzandpose.perch2_category_sets' doesn't exist
SELECT FOUND_ROWS() AS `count`

I've emailed you the ftp and perch login info to hello@grabaperch.com. really appreciate any and all help as i've been trying to fix this for the last 3 days

Drew McLellan

Drew McLellan 2638 points
Perch Support

None of those appear to be from the page with the regions. Can you show me the debug from that page?

You also appear to have a bunch of database issues - so that could be the root cause. If this is a fresh site, I'd suggest dropping the database and reinstalling a fresh copy of 2.8.11.