Forum

Thread tagged as: Problem, Error, Hosting

Can't Login - Sorry, your license key isn't valid for this domain.

One of our sites (http://clevedonchamber.co.uk) has recently moved hosting and now I am unable to login the following error: Sorry, your license key isn't valid for this domain. How can I correct this. Many Thanks

Thyme Morris

Thyme Morris 0 points

  • 1 week ago
Drew McLellan

Drew McLellan 2591 points
Perch Support

The version of PHP on the new hosting is likely much newer, and the older version of Perch you're running isn't compatible with that version of PHP.

You're running Perch 2.8.18 and you need to be on at least 2.8.34. It's a free update from your account.

Sometimes another option if your hosting allows is to switch to an older version of PHP via its control panel. That might work as a temporary fix to get you going while you plan to update.

That's great thanks. I will find out what PHP version they are running. Which PHP version is suitable for the Perch 2.8.18. Should we look at upgarding this site to Perch 3?

Drew McLellan

Drew McLellan 2591 points
Perch Support

If temporarily downgrading, it'll need to be PHP less than v7. Again, only as a short term fix.

You could upgrade to Perch 3, but the minimum to get it working is 2.8.34, which should be a painless update process from 2.8.18.