We are transitioning over to a new forum platform. Please post new issues there. Existing threads will be dealt with here unless you choose to move them over. Visit the new forum

Forum

Thread tagged as: Problem, Blog

Blog app not displaying posts or categories

I've just installed the blog app into an existing Perch install but it's not displaying the post, listing or categories; tags and archive links are showing up from the post I entered but nothing is being output by the default post_in_list.html.

perch_blog_recent_posts(10); & perch_blog_categories(); output nothing.

Prior to installing the app, I upgraded Perch (from 2.4.9 to 2.8.13) and all other apps the latest versions, all of which appeared to work. I added the categories and perch_blog to apps.php.

Any ideas why this might happen?

Adam Green

Adam Green 0 points

  • 4 years ago
Drew McLellan

Drew McLellan 2638 points
Perch Support

Is this a new installation of Blog or an update from an older version?

New installation but an earlier version may have been previously installed and removed. I noticed there was no 'Posts' section like in other working Perch blogs & also that the perch2_blog_sections table was missing from the database so I deleted all the perch2_blog_xxxx tables, reinstalled blog and all working now...

Maybe an earlier version of blog caused the problem, or perhaps adding categories and perch_blog to the apps.php list at the same time.

Drew McLellan

Drew McLellan 2638 points
Perch Support

Ok, great.