We are transitioning over to a new forum platform. Please post new issues there. Existing threads will be dealt with here unless you choose to move them over. Visit the new forum

Forum

Thread tagged as: Problem, Runway, Blog

Empty Blocks until save

Hi, I have the exact same problem described here http://forum.grabaperch.com/forum/04-26-2016-perch-blocks-empty-until-blog-post-published. When creating a blog post and go to edit the blocks, they are empty. https://www.dropbox.com/s/pgjsmple1juel6z/Screen%20Shot%202016-10-07%20at%2023.56.18.png?dl=0

After I hit "save" and come back blocks appear as expected. This happens in both my local environment (mac php 5.6) and staging (linux pfp 7 ).

Diagnostics:

Perch Runway: 2.8.31, PHP: 7.0.11-1~dotdeb+8.1, MySQL: mysqlnd 5.0.12-dev - 20150407 - $Id: 241ae00989d1995ffcbbf63d579943635faf9972 $, with PDO
Server OS: Linux, apache2handler
Installed apps: content (2.8.31), assets (2.8.31), categories (2.8.31), perch_blog (5.0), perch_shop_orders (1.0.8), perch_shop_products (1.0.8), perch_shop (1.0.8), perch_members (1.5), perch_mailchimp (3.0.1)
App runtimes: <?php $apps_list = array( 'content', 'categories', 'perch_blog', 'perch_members', 'perch_shop', 'perch_mailchimp', );
PERCH_LOGINPATH: /admin
PERCH_PATH: /home/70178-54447.cloudwaysapps.com/zbmshpfskk/public_html/admin
PERCH_CORE: /home/70178-54447.cloudwaysapps.com/zbmshpfskk/public_html/admin/core
PERCH_RESFILEPATH: /home/70178-54447.cloudwaysapps.com/zbmshpfskk/public_html/admin/resources
Image manipulation: GD Imagick
PHP limits: Max upload 10M, Max POST 10M, Memory: 128M, Total max file upload: 10M
F1: 2edba60ed1f613d6dd804feb202456a2
Resource folder writeable: Yes
HTTP_HOST: stage-cw.anna-and.co
DOCUMENT_ROOT: /home/70178-54447.cloudwaysapps.com/zbmshpfskk/public_html/
REQUEST_URI: /admin/core/settings/diagnostics/
SCRIPT_NAME: /admin/core/settings/diagnostics/index.php

Template:

<perch:blog id="postSlug" type="slug" label="Post slug" size="xl autowidth" order="1" editable="true" suppress="true" />
<article class="h-entry">
    <h1><perch:blog id="postTitle" type="text" label="Title" required="true" size="xl autowidth" order="2" /></h1>
    <perch:blocks>
        <perch:block type="text" label="Texto">
            <perch:template path="content/simple_text.html" rescope="parent" />
        </perch:block>
        <perch:block type="image" label="Imagen">
            <perch:template path="content/image.html" rescope="parent" />
        </perch:block>
        <perch:block type="list" label="listado">
            <perch:template path="content/list.html" rescope="parent" />
        </perch:block>
    </perch:blocks>

</article>

<perch:blog id="excerpt" type="textarea" label="Excerpt" markdown="true" order="4" suppress="true" size="s" />

Can you see any problems already?

Proko Mountrichas

Proko Mountrichas 3 points

  • 2 years ago
Drew McLellan

Drew McLellan 2637 points
Perch Support

As you say, it sounds like the same problem.

Which just makes us 2 (reported) odd cases not enough to justify further investigation?

Drew McLellan

Drew McLellan 2637 points
Perch Support

Certainly, when the next batch of Blog updates come around.