We are transitioning over to a new forum platform. Please post new issues there. Existing threads will be dealt with here unless you choose to move them over. Visit the new forum

Forum

Thread tagged as: Problem, Runway, Redactor

Runway all wysiwyg editors not uploading images or files

Hi,

I seem to be suffering a very similar issue to this thread: http://forum.grabaperch.com/forum/10-04-2017-assets-empty-when-using-text-editor

However, I did not want to just jump into the same one, just in-case the issue turns out to be different / unique.

This problem has existed for quite sometime (I think since my initial instal of Runway some months ago), but I have been too busy to post on it.

In a nutshell, no matter what editor I use, be it markdown, built in redactor, custom redactor, as soon as I press the 'insert image' or 'file' button, the modal window pops open with the message "No matching assets found".

If I upload say an image via:

<perch:content type="image" id="image" label="Image" width="800" />

all is fine, and I can see ALL the assets when I go straight to the built-in Asset manager.

However, as soon as I try to insert an image or file via the wysiwyg, the modal window opens and the above message appears.

Now after many hours playing around, this is what I seem to have found:

If I use the Assets manager and upload a file to the "default" bucket, when I go to the wysiwyg editor, insert an image and search for this, nothing is returned - "No matching assets"

If I then select "By Bucket" and select "default", I can see a list of the images (I swear this was not happening before) and as such I can select this.

But oddly, if I repeat the above but upload to a different bucket "admin", the image does not appear in the modal window, but searching finds the image straightaway from the home screen of the modal, before I even try to search for it from any of the other tabs.

It seems as if no assts in the "default" bucket, which I presume is automatically set-up as the

admin/resources

folder ?

It's almost as if I need to haev something like:

define('PERCH_DEFAULT_BUCKET', '/');

in my config.php, to tell runway that the resources folder is the default bucket ??

It's odd that it is happening for lot's of different wysiwyg editors and different installations.

Maybe there is somethign wrong with my installation, or the way I have set things up, but it all seems pretty standard.

Any ideas, greatly welcome.

My Diagnostis report is below:

    Perch Runway: 3.0.10, PHP: 5.6.31, MySQL: mysqlnd 5.0.11-dev - 20120503 - $Id: 76b08b24596e12d4553bd41fc93cccd5bac2fe7a $, with PDO
    Server OS: Linux, cgi-fcgi
    Installed apps: content (3.0.10), assets (3.0.10), categories (3.0.10), perch_blog (5.6.1), perch_events (1.9.5), perch_forms (1.9), perch_shop_orders (1.2.5), perch_shop_products (1.2.5), perch_shop (1.2.5), perch_members (1.6.2), perch_twitter (3.7)
    App runtimes: <?php $apps_list = [ 'perch_blog', 'perch_twitter', 'perch_events', 'perch_forms', 'perch_members', 'perch_shop', ];
    PERCH_LOGINPATH: /admin
    PERCH_PATH: /home/auk/public_html/admin
    PERCH_CORE: /home/auk/public_html/admin/core
    PERCH_RESFILEPATH: /home/auk/public_html/admin/resources
    Image manipulation: GD Imagick
    PHP limits: Max upload 12M, Max POST 12M, Memory: 64M, Total max file upload: 12M
    F1: 3b606135b33e6a102526838f4152a807
    Resource folder writeable: Yes
    DOCUMENT_ROOT: /home/auk/public_html
    HTTP_HOST: anticoagulationuk.org
    REQUEST_URI: /admin/core/settings/diagnostics/
    SCRIPT_NAME: /admin/core/settings/diagnostics/index.php
Andrew Kennedy

Andrew Kennedy 0 points

  • 2 years ago

I had a similar problem ... in the perch tag in the template, I had to define the bucket like bucket=“default” or something similar

Perfect, thank you so much for sharing.

Yes, this did the trick !

How annoying, oh well, at least it is resolved. I just need to go and edit all my templates now.

Thanks Blake for taking the time to reply, really appreciated.

Any time ... I've had LOTS of people help me, so its good to give back a little!