We are transitioning over to a new forum platform. Please post new issues there. Existing threads will be dealt with here unless you choose to move them over. Visit the new forum

Forum

Thread tagged as: Error

Warning error after updating

Following on this thread;

link

I'm noticing all the v2 Perch websites have the message;

Warning: count(): Parameter must be an array or an object that implements Countable in /home/XXXXXXXXXX/public_html/perch/core/lib/PerchFieldTypes.class.php on line 69

I've recently updated our server to php7.2 and for all v2 sites I updated them to 2.8.34. The fix to upgrade the site in the other thread to V3 was OK as it was a simple site, but I currently have about 30 v2 sites and I've generally only updating to v3 when they've required working on. Is upgrading to v3 the only way to get round this error? The front-end of the sites are OK its just in the admin I get this message.

Wayne Hooper

Wayne Hooper 6 points

  • 1 year ago

Drop PHP to 7.0 and the error will go away. It's actually a warning... not really an error.

Thanks Robert. Oh yeah, just seen its a warning. I'll instal 7.0 on our server and use that for v2 sites.