Forum

Thread tagged as: Problem, Error

Special characters missing in URL

To compose the project URLs, I create a slug using client and project names. For example: "Discovery Channel, Gorączka złota" becomes "discovery-channel-goraczka-zlota"... or at least it should. After moving our website to a new server, the special characters "ą" and "ł" went missing after editing the entry (it became "discovery-channel-gorczka-zota"). See here: https://just.com.pl/work/discovery-channel-gorczka-zota Is it something I can fix from Perch side, or is it a server issue?

Diagnostic Report:

Perch: 3.0.11, PHP: 5.4.16, MySQL: 5.5.50-MariaDB, with PDO
Server OS: Linux, apache2handler
Installed apps: content (3.0.11), assets (3.0.11), categories (3.0.11)
App runtimes: <?php $apps_list = array( 'content', 'categories', );
PERCH_LOGINPATH: /cms
PERCH_PATH: /data/websites/just.com.pl/account/www/cms
PERCH_CORE: /data/websites/just.com.pl/account/www/cms/core
PERCH_RESFILEPATH: /data/websites/just.com.pl/account/www/cms/resources
Image manipulation: GD
PHP limits: Max upload 128M, Max POST 128M, Memory: 64M, Total max file upload: 64M
F1: 9fab42554990d2c203d599a6437edd2a
Resource folder writeable: Yes
HTTP_HOST: just.com.pl
DOCUMENT_ROOT: /data/websites/just.com.pl/account/www/
REQUEST_URI: /cms/core/settings/diagnostics/
SCRIPT_NAME: /cms/core/settings/diagnostics/index.php
Paul O'Rely

Paul O'Rely 0 points

  • 1 week ago
Drew McLellan

Drew McLellan 2406 points
Perch Support

Does your new server have the intl extension installed? In particular I think you want the Transliteration functions.

No, it doesn't have this extension installed. I'll have a look into it, thanks!