We are transitioning over to a new forum platform. Please post new issues there. Existing threads will be dealt with here unless you choose to move them over. Visit the new forum

Forum

Thread tagged as: Hosting

Install on GoDaddy issue

Hi,

A client would like to use their existing GoDaddy hosting for a project.

When I install Perch, visiting /perch/setup in the browser returns:

Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /home/content/21/5761821/html/perch/setup/server/index.php on line 2

Parse error: syntax error, unexpected T_STRING, expecting T_CONSTANT_ENCAPSED_STRING or '(' in /home/content/21/5761821/html/perch/setup/server/index.php on line 2

Visiting just /perch returns:

Warning: include(DIR/inc/pre_config.php) [function.include]: failed to open stream: No such file or directory in /home/content/21/5761821/html/perch/core/index.php on line 4

Warning: include() [function.include]: Failed opening 'DIR/inc/pre_config.php' for inclusion (include_path='.:/usr/local/php5/lib/php') in /home/content/21/5761821/html/perch/core/index.php on line 4

Warning: Cannot modify header information - headers already sent by (output started at /home/content/21/5761821/html/perch/core/index.php:4) in /home/content/21/5761821/html/perch/core/index.php on line 8

Any ideas? Thanks.

Franz Neumann

Franz Neumann 0 points

  • 3 months ago

Franz,

What version of Perch are you trying to install? What version of PHP is installed on the server?

Making sure your using most recent release of Perch v2 or v3 is very important, as well, you should be using PHP 7 (you could use previous stable, but why on a new install).

This information will help us to troubleshoot your issues.

It's the very latest version of Perch. There's an existing site up on PHP 5.2. The highest option that's also listed is 5.6, unfortunately.

Franz Neumann said:

It's the very latest version of Perch. There's an existing site up on PHP 5.2. The highest option that's also listed is 5.6, unfortunately.

Important note

Perch and Runway both require PHP 5.4, but you should always run the newest release of PHP available to you. We always advocate updating your staging or development copy of the site and testing the changes first. We do not recommend updating a live site without checking everything’s going to work first.