Thread tagged as: Problem, Error, Configuration

Scheduled Tasks


I've had a headache trying to set up scheduled tasks with Heart Internet after many threads of support I've finally managed to get that working correctly. Although the task does not run I get this error email:

Unable to create required database tables.


Perch Runway: 2.7.10, PHP: 5.5.20, MySQL: mysqlnd 5.0.11-dev - 20120503 - $Id: bf9ad53b11c9a57efdb1057292d73b928b8c5c77 $, with PDO
Server OS: Linux, cgi-fcgi
Installed apps: content (2.7.10), assets (2.7.10), categories (2.7.10), perch_blog (4.5.4), perch_events (1.9), perch_forms (1.8.2), perch_gallery (2.8.5), collection_6 (2.7.10), collection_2 (2.7.10), perch_twitter (3.5.1)
App runtimes: <?php $apps_list = array( 'content', 'categories', 'perch_forms', 'perch_events', 'perch_gallery', 'perch_blog', 'perch_twitter', );
PERCH_PATH: /home/sites/
PERCH_CORE: /home/sites/
Image manipulation: GD
PHP limits: Max upload 64M, Max POST 64M, Memory: 128M, Total max file upload: 64M
Resource folder writeable: Yes
DOCUMENT_ROOT: /home/sites/
REQUEST_URI: /admin/core/settings/diagnostics/
SCRIPT_NAME: /admin/core/settings/diagnostics/index.php
Dexter Harrison

Dexter Harrison 29 points

  • 6 years ago
Drew McLellan

Drew McLellan 2638 points
Perch Support

What happens when you run it by hand with the URL?

Works absolutely fine

Drew McLellan

Drew McLellan 2638 points
Perch Support

Do you switch configuration based on host name?

Yes i do, I can change that if it's causing the issue

Changing that has fixed the problem, it's a shame i can't use both

Drew McLellan

Drew McLellan 2638 points
Perch Support

You can - just make the production server the default for if no hostname matches. (There's no hostname for a cron job, as it's a command line request, not through a web server.)