Thread tagged as: Question, Configuration

Creating pages without .php extension

Perch automatically adds .php to filenames when creating pages.

Is there a way to stop Perch doing this?

Neil Duddridge

Neil Duddridge 1 points

  • 4 years ago
Rachel Andrew

Rachel Andrew 394 points
Perch Support

If you are rewriting URLs then you can hide extensions

Add an option of ‘hide-extensions’ => true to the array when outputting the navigation.

Ah that's it!

I had done the .htaccess stuff but not 'hide-extensions' in the array.

Sorted! :)