Thread tagged as: Error, Runway, Backup

Dropbox backup error on Runway 3.1.1

After updating to Runway 3.1.1, I get the error:

PHP Parse error:  syntax error, unexpected '->' (T_OBJECT_OPERATOR) in /home/2/d/dunderverk/www/dv-cms/core/runway/apps/perch_dropbox/vendor/tightenco/collect/src/Collect/Support/Collection.php on line 155

Which refers to this part of that file:

        $values = (isset($key) ? $this->pluck($key) : $this)

Anyone else experiencing this issue, or have any idea on how to solve it?

Worked perfectly until the latest update.

Perch Runway: 3.1.1, PHP: 7.0.27-0+deb9u1, MySQL: mysqlnd 5.0.12-dev - 20150407 - $Id: b5c5906d452ec590732a93b051f3827e02749b83 $, with PDO
Server OS: Linux, cgi-fcgi
Installed apps: content (3.1.1), assets (3.1.1), categories (3.1.1), perch_blog (5.6.1), perch_forms (1.10), perch_shop_orders (1.2.5), perch_shop_products (1.2.5), perch_shop (1.2.5), perch_members (1.6.2), redfinch_logger (1.0.1)
App runtimes: <?php $apps_list = [ 'perch_forms', 'perch_blog', 'perch_members', 'perch_shop', ];
Image manipulation: GD Imagick
PHP limits: Max upload 128M, Max POST 128M, Memory: 129M, Total max file upload: 128M
F1: 3b606135b33e6a102526838f4152a807
Resource folder writeable: Yes
Eddie Dale

Eddie Dale 0 points

  • 3 years ago
Drew McLellan

Drew McLellan 2638 points
Perch Support

Which version did you update from?

I believe it was from 3.0.14.

Drew McLellan

Drew McLellan 2638 points
Perch Support

That's really odd. I can't get it to fail here, but I'll keep trying.

Thanks! Let me know if it would be helpful with more information.

Are there no one else with this issue, and still no success in recreating the error, Drew?

I have tried updating the core without luck. Still getting the same error.

Any pointers as to what to try out would be helpful. A little unsure where to start fixing the issue.

Drew McLellan

Drew McLellan 2638 points
Perch Support

It's a problem in one of the dependancies of the Dropbox SDK that only shows up in some environments. You can see details here:

You're on PHP 7, so I don't know why you're seeing any issues. I've updated the dependancies for the latest release, so we'll have to see if that helps.

Great, thanks for taking the time to investigate!

I believe shell (and therefore the cronjob) runs on an older php version. At least I get the email from Cron Deamon: Cron <dunderverk@php56-shell>

So that would explain why I also see the issue.

Looking forward to the upcoming release then :-)

Drew McLellan

Drew McLellan 2638 points
Perch Support

Ah, you should update your CLI PHP too!