Thread tagged as: Problem, Runway

Runway User Roles - Collection options not available

For some reason, every time I create a new Runway install, I always need to run this on the db to make the collection options appear:

INSERT INTO `perch3_user_privileges` (`privKey`, `privTitle`, `privOrder`)
('content.collections.create', 'Create collections', 99),
('content.collections.delete', 'Delete collections', 99),
('content.collections.manage', 'Manage collections', 99),
('content.collections.options', 'Manage collection options', 99);

I have 7 Runway sites and I've had to do this to all of them, whether they were upgraded from Perch or started with Runway.


Perch Runway: 3.1.1, PHP:, MySQL: mysqlnd 5.0.11-dev - 20120503 - $Id: 3c688b6bbc30d36af3ac34fdd4b7b5b787fe5555 $, with PDO
Server OS: Linux, apache2handler
Installed apps: content (3.1.1), assets (3.1.1), categories (3.1.1)
App runtimes: <?php $apps_list = [ ];
PERCH_PATH: /var/www/public/thereserveatholidaylanding.localdev/rhl-admin
PERCH_CORE: /var/www/public/thereserveatholidaylanding.localdev/rhl-admin/core
PERCH_RESFILEPATH: /var/www/public/thereserveatholidaylanding.localdev/rhl-admin/resources
Image manipulation: GD Imagick
PHP limits: Max upload 100M, Max POST 100M, Memory: 128M, Total max file upload: 100M
F1: 3b606135b33e6a102526838f4152a807
Resource folder writeable: Yes
HTTP_HOST: thereserveatholidaylanding.localdev
DOCUMENT_ROOT: /var/www/public/thereserveatholidaylanding.localdev
REQUEST_URI: /rhl-admin/core/settings/diagnostics/
SCRIPT_NAME: /rhl-admin/core/settings/diagnostics/index.php
Shane Lenzen

Shane Lenzen 18 points

  • 3 years ago
Drew McLellan

Drew McLellan 2638 points
Perch Support

We're taking another look at this.

So is this the best way to make it work for now? I'm having same issues when I tried to give an 'Editor' role for collections. Is the 'privOrder' = 99 best?

Linda, this is what I've been doing per Drew's recommendation and I haven't run into any problems so far.

Thanks for the quick response. I added these to the DB and it's still not showing for an editor. Did you make any other changes? (They are showing in the table correctly.)

Do your other tables start with perch3_? If your site was upgraded from Perch 2 you may need to use perch2_

All tables start with perch3_ as it's a new install. It's strange it's not working, was hoping this would fix the issue.