Thread tagged as: Question, Runway

Amazon S3 to be the default bucket not working

Hi there,

We have configured Amazon S3 successfully using a bucket called resources.

This is our buckets.php file

    return [
        'resources' => [
            'type'      => 'amazon_s3',
            'region'    => 'eu-west-2',
            'web_path'  => '',
            'file_path' => 'xxxx',

This is our runway.php file

'amazon_s3' => [

    'access_key_id'     => 'xxxx',
    'secret_access_key' => 'xxxx',
    'handler'           => 'PerchS3_ResourceBucket',
    'handler_path'      => PERCH_CORE.'/runway/apps/perch_s3/PerchS3_ResourceBucket.class.php',


Then in our config.php file we have defined our default bucket


But when I login to Perch admin and upload any assets the default bucket always shows first. When you upload images to this bucket it saves to /resources locally. The client always has to switch to the resources bucket in order for them to be saved on Amazon S3.

Do you guys have any ideas how to set the default bucket to save to Amazon S3.

Here is my Diagnostics

Perch Runway: 3.0.4, PHP: 5.6.30, MySQL: mysqlnd 5.0.11-dev - 20120503 - $Id: 76b08b24596e12d4553bd41fc93cccd5bac2fe7a $, with PDO
Server OS: Darwin, apache2handler
Installed apps: content (3.0.4), assets (3.0.4), categories (3.0.4)
App runtimes: <?php $apps_list = [ ];
PERCH_PATH: /Users/Barry/Sites/just-voices/admin
PERCH_CORE: /Users/Barry/Sites/just-voices/admin/core
PERCH_RESFILEPATH: /Users/Barry/Sites/just-voices/admin/resources
Image manipulation: GD Imagick
PHP limits: Max upload 32M, Max POST 32M, Memory: 128M, Total max file upload: 32M
F1: 0c66c2e1f82f9e0b7617b2cb8270f2c7
Resource folder writeable: Yes
HTTP_HOST: just.voices
DOCUMENT_ROOT: /Users/Barry/Sites/just-voices
REQUEST_URI: /admin/core/settings/diagnostics/
SCRIPT_NAME: /admin/core/settings/diagnostics/index.php

Thanks Barry

Fishtank Creative

Fishtank Creative 2 points

  • 4 years ago

Very strange but when I change the name of my bucket it works fine. It must be because the name was called resources