Thread tagged as: Problem, Gallery

HTTP error when uploading images


When I attempt to upload images to the gallery, when the image gets to 100% a yellow warning triangle appears which when hovered over suggests an HTTP error. When uploading images to assets the image disappears just before the progress bar gets to the end. Only on my live server though, local build still works fine. The last thing I did was enable compression via cPanel, but deactivating it hasn't rectified it.


Perch: 2.8.7 Production mode: Production (100) Installed apps: content (2.8.7), assets (2.8.7), categories (2.8.7), perch_blog (4.6), perch_forms (1.8.3), perch_gallery (2.8.6), perch_backup (1.2) DB driver: MySQLi DB tables: perch2_blog_authors, perch2_blog_comments, perch2_blog_index, perch2_blog_posts, perch2_blog_posts_to_tags, perch2_blog_sections, perch2_blog_tags, perch2_categories, perch2_category_counts, perch2_category_sets, perch2_content_index, perch2_content_items, perch2_content_regions, perch2_forms, perch2_forms_responses, perch2_gallery_albums, perch2_gallery_image_versions, perch2_gallery_images, perch2_navigation, perch2_navigation_pages, perch2_page_templates, perch2_pages, perch2_resource_log, perch2_resource_tags, perch2_resources, perch2_resources_to_tags, perch2_settings, perch2_user_privileges, perch2_user_role_privileges, perch2_user_roles, perch2_users Users: 4 App runtimes: <?php $apps_list = array( 'content', 'categories', 'perch_gallery', 'perch_blog', 'perch_forms', ); Scheduled tasks for perch_blog: delete_spam_comments (1440 mins) Editor plug-ins: ckeditor, tinymce, redactor, markitup H1: 67615acb424802b0f49ddaa8c3e8399a L1: 58171556e8cc89b5374107af83086924 headerColour: #0080c0 content_singlePageEdit: 1 helpURL: siteURL: / hideBranding: 0 content_collapseList: 1 lang: en-gb update_2.7.10: done latest_version: 2.8 on_sale_version: 2.8.7 perch_gallery_update: 2.8.5 update_2.8.2: done perch_blog_update: 5.0 perch_blog_post_url: /blog/post.php?s={postSlug} update_2.8.4: done headerScheme: dark perch_gallery_bucket_mode: single perch_gallery_bucket: default perch_blog_slug_format: %Y-%m-%d-{postTitle} perch_blog_akismet_key: perch_blog_max_spam_days: 0 perch_backup_mysqldump_path: dashboard: 0 hide_pwd_reset: 0 content_hideNonEditableRegions: 0 content_frontend_edit: 0 perch_gallery_basicUpload: 0 perch_blog_comment_notify: 0 update_2.8.6: done update_2.8.7: done PERCH_DEVELOPMENT: 10 PERCH_STAGING: 50 PERCH_PRODUCTION: 100 PERCH_DB_USERNAME: pixels_longshot PERCH_DB_SERVER: localhost PERCH_DB_DATABASE: pixels_longshot PERCH_DB_PREFIX: perch2_ PERCH_TZ: Europe/London PERCH_EMAIL_FROM: PERCH_EMAIL_FROM_NAME: Mark Phoenix PERCH_LOGINPATH: /perch PERCH_PATH: /home/pixels/public_html/clients/dev/perch PERCH_CORE: /home/pixels/public_html/clients/dev/perch/core PERCH_RESFILEPATH: /home/pixels/public_html/clients/dev/perch/resources PERCH_RESPATH: /perch/resources PERCH_HTML5: 1 PERCH_RUNWAY: PERCH_ERROR_MODE: DIE PERCH_DATE_LONG: %d %B %Y PERCH_DATE_SHORT: %d %b %Y PERCH_TIME_SHORT: %H:%M PERCH_TIME_LONG: %H:%M:%S PERCH_DEBUG: PERCH_PREVIEW_ARG: preview PERCH_TEMPLATE_PATH: /home/pixels/public_html/clients/dev/perch/templates PERCH_DEFAULT_DOC: index.php PERCH_DEFAULT_EXT: .php PERCH_PRODUCTION_MODE: 100 PERCH_RWD: PERCH_HTML_ENTITIES: PERCH_SSL: PERCH_STRIPSLASHES: PERCH_PROGRESSIVE_FLUSH: 1 PERCH_AUTH_PLUGIN: PERCH_DB_CHARSET: PERCH_DB_PORT: PERCH_DB_SOCKET: Hosting settings PHP: 5.4.37 Zend: 2.4.0 OS: Linux SAPI: cgi-fcgi Safe mode: not detected MySQL client: 5.5.42 MySQL server: 5.5.42-cll Extensions: Core, date, ereg, libxml, openssl, pcre, sqlite3, zlib, bcmath, calendar, ctype, curl, dom, filter, ftp, gd, hash, iconv, SPL, json, mcrypt, mysql, mysqli, session, standard, posix, Reflection, Phar, SimpleXML, sockets, imap, tokenizer, xml, xmlreader, xmlwriter, cgi-fcgi GD: Yes ImageMagick: No PHP max upload size: 8M PHP max form post size: 8M PHP memory limit: 64M Total max uploadable file size: 8M Resource folder writeable: Yes Session timeout: 24 minutes Native JSON: Yes Filter functions: Yes Transliteration functions: No DOCUMENT_ROOT: /home/pixels/public_html/clients/dev GATEWAY_INTERFACE: CGI/1.1 HTTP_ACCEPT: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8 HTTP_ACCEPT_ENCODING: gzip, deflate HTTP_ACCEPT_LANGUAGE: en-GB,en;q=0.5 HTTP_CONNECTION: keep-alive HTTP_COOKIE: cmsa=1; PHPSESSID=f13f080c3d9f5043cb45ed5b8db21733 HTTP_HOST: HTTP_REFERER: HTTP_USER_AGENT: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0 PATH: /bin:/usr/bin QUERY_STRING: extended REDIRECT_STATUS: 200 REMOTE_ADDR: REMOTE_PORT: 50044 REQUEST_METHOD: GET REQUEST_URI: /perch/core/settings/diagnostics/?extended SCRIPT_FILENAME: /home/pixels/public_html/clients/dev/perch/core/settings/diagnostics/index.php SCRIPT_NAME: /perch/core/settings/diagnostics/index.php SERVER_ADDR: SERVER_ADMIN: SERVER_NAME: SERVER_PORT: 80 SERVER_PROTOCOL: HTTP/1.1 SERVER_SOFTWARE: Apache UNIQUE_ID: VWV4dKINLKAAAC8bYLcAAAA1 PHP_SELF: /perch/core/settings/diagnostics/index.php REQUEST_TIME_FLOAT: 1432713332.97 REQUEST_TIME: 1432713332 argc: 1
Mark Phoenix

Mark Phoenix 0 points

  • 6 years ago
Rachel Andrew

Rachel Andrew 394 points
Perch Support

What size are the images you are uploading, are you trying to upload multiple images?

You limit is 8MB max upload so anything over that will not work.

I'm not uploading anything near 8MB, it's failed with images as small as 600KB. And it's not working with single and multiple images.

Uploading text to regions and blog posts works fine though...

Drew McLellan

Drew McLellan 2638 points
Perch Support

So this is solved?

Sorry no. That was my fat thumbs on my mobile.

Drew McLellan

Drew McLellan 2638 points
Perch Support

What's the HTTP error you're getting?

After some digging it was the .gitignore file in the core which was preventing files uploading to the live site, which was why the local site was working and the live site wasn't.