Thread tagged as: Problem, Blog

Asset Upload - Images not being processed

OK, had an issue previously with images being deleted from Assets even though they were being used in Blog post. So read up and upgraded to latest version.

Then tried to upload the images that were deleted and they upload but as the Asset library refreshes, they are not there???

I checked the FTP and I can see the original image jeep1newyork2015.jpg (1.3MB) is uploaded but no processed image thumbs or cropped sizes. I do also see some kind of temp file... (_gd_tmp_WNIDlE) but it has zero bytes and the same time/date stamp. I tried renaming and also tried uploading some other images, same deal.

I had already turned on debug and no errors were thrown in CMS. I also checked cPanel error log - nothing...

I looked up these last uploads under the Resource Log and the "resourceKey" in DB has no info and the temp image is not listed in DB. However the image reference in DB is one of the cropped image sizes??

So I deleted the entire Blog entry and tried adding again.

Then I added the 3 of the 6 that were already in Assets and tried saving, then I go this error:

Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 8525249 bytes) in ../public_html/stage/cms/core/lib/PerchImage.class.php on line 730

So I removed the Blog entry again. Under Blog/Sections it says 16 posts, but there is only 15?

This hosting is not ours, and is on a shared Go Daddy server in the US.


Perch: 2.8.8, PHP: 5.4.37, MySQL: mysqlnd 5.0.10 - 20111026 - $Id: c85105d7c6f7d70d609bb4c000257868a40840ab $, with PDO Server OS: Linux, cgi-fcgi Installed apps: content (2.8.8), assets (2.8.8), categories (2.8.8), perch_blog (4.6), perch_forms (1.8.3) App runtimes: <?php $apps_list = array( 'content', 'categories', 'perch_blog', 'perch_forms', ); ?> Image manipulation: GD Imagick PHP limits: Max upload 32M, Max POST 48M, Memory: 64M, Total max file upload: 32M Resource folder writeable: Yes

Since we had already uploaded 15 Blog entries that are galleries with large images not sure what is going on...

Let me know if there is any tests or changes I can make.


Stuart Farrell

Stuart Farrell 0 points

  • 6 years ago
Rachel Andrew

Rachel Andrew 394 points
Perch Support

You are running out of memory to process the image. So Perch cannot create the sizes.

Shared hosting means the memory is shared with all other sites so the stated amount of memory is not necessarily close to what you actually have available.

Our suggestion would be to not use GoDaddy, they are not a great host. If the client is insisting on staying with a poor hosting company they will need to resize their images to be smaller before uploading them.

Yeah, kinda suspected that... but wasn't sure as we didn't always get the error. Will ask them to upgrade to double the RAM, but we did advise at start of project to move to a decent service. :-(