Thread tagged as: Problem, Configuration, Blog

404 on blog posts

Hi again..

I've installed Perch and the blog app and most of it seems OK although one thing is puzzling me. I can create posts fine and they show up in the latest feed, however if I try and go to the post itself it seems to want to strip the WDD4 out of the URL. Example

If you click any of the items in the list it wants to go to (eg) (i.e missing the WDD4).

Now nothing relating to Perch nor the blog sits in the site root so I can only assume that it is aiming for the site's HTTP Host


PERCH_LOGINPATH: /wdd4/perch PERCH_PATH: /home/ghubba02/htdocs/wdd4/perch PERCH_CORE: /home/ghubba02/htdocs/wdd4/perch/core PERCH_RESFILEPATH: /home/ghubba02/htdocs/wdd4/perch/resources Image manipulation: GD PHP limits: Max upload 7M, Max POST 7M, Memory: 90M, Total max file upload: 7M Resource folder writeable: Yes HTTP_HOST: DOCUMENT_ROOT: /home/ghubba02/htdocs REQUEST_URI: /wdd4/perch/core/settings/diagnostics/ SCRIPT_NAME: /wdd4/perch/core/settings/diagnostics/index.php

I tried updating the Live Domain field on my account (as it's missing the WDD4 where it resides) but now when I go to login to the Perch CRM I get the error

"Sorry, your license key isn't valid for this domain. Log into your Perch account and add the following as your live or testing domain:"

Thanks again in advance


Graeme Hubbard

Graeme Hubbard 0 points

  • 7 years ago
Rachel Andrew

Rachel Andrew 394 points
Perch Support

Have you set the path to your blog post page in Perch Settings?

Yes, just set it in the Blog post page path field and it is now sorted. I got a little confused as the video made it look like it would work straight away. Thanks again for your quick response.