Thread tagged as: Problem, Error, Configuration

Can't Log in to Perch Admin

I can't log in to the perch admin back end at When trying to do so, the system shows incorrect username / password. I've tried updating the username / password directly in the database but it still does not work. When I use the password reset feature, it sends the reset email, changes the password in the database (I can see the encrypted password field change) but it still does not allow me to log in. Any help in solving this issue would be GREATLY appreciated.

  • Marc
Marc Rassel

Marc Rassel 0 points

  • 3 years ago
Drew McLellan

Drew McLellan 2638 points
Perch Support

Has PHP been updated on your server? You're running a very old version of Perch, so if PHP has been updated you could be seeing an incompatibility.

That's possible, but unfortunately it's on a server I don't really have control over.

If im not wrong , try to contact your host provider . They might be able to help you out with this .

I've cloned everything over to a new development server ( where I have control over server settings, updated the PHP version (to many different versions) and am still getting the same error. There are two users in the database and both present the same issue. I've also upgraded Perch to the latest version with no change.

Could it be session storage issues? although unlikely since the same thing happens in different servers. Can you show us your PHP session save path variables? can you show us your error log? can you enable debug and paste the results here?

Here are the debug results:

Debug Message - Perch 3.1.1 SELECT u.*, r.* FROM perch2_users u, perch2_user_roles r WHERE u.roleID=r.roleID AND u.userEnabled=1 AND userUsername='mrassel' LIMIT 1 Invalid query: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'jamminjim_perch.perch2_user_roles' doesn't exist Writing auth fail to log. [15] SELECT DISTINCT settingID, settingValue FROM perch2_settings WHERE userID=0 Queries: 1 Memory: 0.7841

I answered my own question now - somehow the user roles table didn't exist in the database so I added that and all is working well now. Thank you all for the quick replies!

Ahem. Drew and everyone who questioned me ^. It's still strange that this happens on random user tables.

Edit. Can we get a final table check on the install process?