Thread tagged as: Problem, Suggestions, Twitter

Same problem with Editors scheduling Tweet App in v3

Hi, 8 months ago I started a thread about a problem I was having with allowing my client (who is set up as Editor) to schedule a Tweet. As per the last thread, I am still able to schedule a Tweet via the 'Admin' login but not when logged in as 'Editor'. Obvious this is an issue for my client, as I told him he could manage his Tweets from his Perch dashboard. :-(

Below is the link to my last thread and a screenshot of the permissions I have set up for the Role of Editor.

Permissions set for Editor Role

Julie Harding

Julie Harding 0 points

  • 4 years ago

Sorry I forgot to mention: Perch version 3.0.8 Twitter App version 3.7

Drew McLellan

Drew McLellan 2638 points
Perch Support

We've got it logged so should be able to fix it in the next Twitter update.

In the meantime you can turn on priv assist to enable the privilege.

Hi Drew, Where do I turn on 'priv assist'?

Drew McLellan

Drew McLellan 2638 points
Perch Support

In your config.php file:

define('PERCH_PRIV_ASSIST', true);

Then the privilege should be created when you try to access it.

Hi Drew, I have added priv assist to the config file but it doesn't seem to have made any difference.

I also set up a test role with all privilege selected and then login into a test user set up with this role and still not able to add a Tweet??

Doe this mean my client will have to wait for the next version of the Twitter App update? Or have I missed something?

Duncan Revell

Duncan Revell 78 points
Registered Developer


try the steps mentioned here

It's for the events app, but the steps should hopefully work for you too with the twitter app.