Thread tagged as: Problem, Blog

Links in blog posts not rendering (markitup, textile)

Update: The system will only render the link if the https:// is not present in that string. So textile code "text": won't render the link, but "text" will. Of course this means the link won't work correctly due to pathing.

In a blog post, when a link is inserted via the markitup toolbar icon, the code inserted is "linktext": Upon saving this post and reloading the blog post, the link html does not render. The above markitup template text appears on the page instead.

I've just upgraded a client from 2.5.4 to 2.8.9 hoping that it would resolve the issue, but sadly it remains (the updated markitup folder was copied over as instructed).

The client has used textile formatting for all of their blog post. Switching to markdown, the markdown link code does work, but then every post would have to be manually updated from textile to markdown formatting, which I'd rather avoid.

Post Description template tag

<perch:blog id="postDescHTML" type="textarea" label="Post" order="2" editor="markitup" textile="true" size="xxl autowidth" required="true" />


Perch: 2.8.9, PHP: 5.3.3, MySQL: 5.0.83, with PDO
Server OS: Linux, apache2handler
Installed apps: content (2.8.9), assets (2.8.9), categories (2.8.9), perch_blog (4.6), perch_backup (1.2)
App runtimes: <?php $apps_list = array( 'content', 'categories', 'perch_blog', ); ?>
Image manipulation: GD
PHP limits: Max upload 16M, Max POST 16M, Memory: 128M, Total max file upload: 16M
Resource folder writeable: Yes
REQUEST_URI: /manage/core/settings/diagnostics/
SCRIPT_NAME: /manage/core/settings/diagnostics/index.php
Adrian Payne

Adrian Payne 0 points

  • 6 years ago
Drew McLellan

Drew McLellan 2638 points
Perch Support

That sounds very odd. Does the same happen in a content region?

Just tested and, yes, it happens on a regular content region as well. This was the test tag:

<perch:content id="testextile" type="textarea" label="Text" editor="markitup" textile="true" imagewidth="640" imageheight="480" />
Drew McLellan

Drew McLellan 2638 points
Perch Support

I can't reproduce this. Are you certain that you've not got smart quotes or something like that?

This text works for me:

"This is a link":

Is there any way I can help you troubleshoot this? Something to check for in phpinfo or..?

gif of the issue

Drew McLellan

Drew McLellan 2638 points
Perch Support

Have you tried in a different browser?

Yes, so same result in Firefox and Chrome :/

Drew McLellan

Drew McLellan 2638 points
Perch Support

Is this your dev environment on live? Does it happen the same everywhere?

Sorry! Should have mentioned that! Only happens on live shared hosting. Localhost with WAMP is fine.

Drew McLellan

Drew McLellan 2638 points
Perch Support

I can't think what would cause that. Obviously you're on a very old version of PHP, but this stuff hasn't changed in years. It makes no sense.

I know this is a really old post but did you find a resolution Adrian?

I've got the exact same issue. Fine on localhost, not rendering on live site.

Rachel Andrew

Rachel Andrew 394 points
Perch Support

John, if you'd like help could you raise your own thread with template and Diagnostics Report?

I didn't particularly want to bother you guys with a new thread this close to Christmas. Just thought there might be a quick solution based on a past case.

Don't worry, it gives me the incentive to move the blog on this particular site to use Markdown. There are only 4 posts so it's not a big job.

Have a good Christmas and thanks as always for your help.

Hi John. Sadly, I never did find the cause or a solution. Just worked around the issue!

Thanks for your reply Adrian. Appreciate it.