Thread tagged as: Problem

Assets disappearing

We are finding that several of our Assets disappear after a time.

We go through the Add Asset process, choose a legitimate .jpg file, select 'Mark as library asset' and for a time the asset appears. We choose the default bucket. It's the only one we have.

24 hours later and many of the ones we added are gone.

We went through a clearing out process, removing all dupes and are in the process of building up our Assets library for future use. Some of the ones that disappeared have not yet made an appearance on a page, but my understanding is that 'library asset' status protects unused ones from being purged.

Stefan Youngs

Stefan Youngs 0 points

  • 7 years ago
Drew McLellan

Drew McLellan 2638 points
Perch Support

It doesn't protect them from being manually deleted.

We didn't manually delete them.

I should have said the images themselves disappear but their memories linger on

This refers

Rachel Andrew

Rachel Andrew 394 points
Perch Support

That looks as if an image has been manually deleted. If Perch cleans up it cleans up everything. We do not advise going through any sort of manual "clearing out" process as this sort of thing is likely to happen.

So we can't really help in this instance, you've already said that you have been deleting assets. So we have no way to know whether or not you removed assets that you thought were unused actually were in use. We would suggest that you leave Perch to manage Assets through the history stack in future.

I specifically asked for advice about clearing out duplicates and did so. The original process Perch used to create our Assets brought in lots of dupes, which we needed to clear out.

After this process was completed, I then began the process of loading in NEW assets under NEW names. The problem I report has ONLY occurred with NEW Assets I brought in after the clear-out. I've deleted nothing since I started to load in new assets.

We don't have the usecase for Assets that are used once and then no longer used. Everything in our Assets is there because we want to reuse it in the future. They are permanent. Or they would be if they did not disappear!

Rachel Andrew

Rachel Andrew 394 points
Perch Support

No-one else is reporting this, and because you have been deleting assets manually then we can't reproduce your specific situation.

I can assure you that if we get reproduceable reports of this happening we will be onto it as a priority.

Well, I understand your scepticism, but all is as I say. It's as if your purge process is removing the image but leaving its 'container', giving the ghost effect seen in my link above. I can't see how this can be related to my clean-up because the new files not only had new names in the file-naming area in Perch, but the file names themselves were new (1crest.jpg for example has never previously been in Assets)

All the 'ghosts' seen in my link (above) are files added yesterday. There are no ghosts appearing in page 2 (or greater) of the Assets, even though there are files on those pages added around the same time as the ghosts on page 1

I'll report back tomorrow with a status report on the file I just added this morning. It's the first one in the screenshot. My guess is that it will have transformed into a ghost.

Since we want this facility to work, how about we completely delete our Assets and start over? How do we do this?


Have you tried reloading the pages and then adding the new assets? I have deleted assets and not had any problems.

Hi. Thanks for taking the trouble to respond. Our problem seems to be that some Assets we add are having the image content purged after a period of time. The filename and details remain visible, but in the Assets panel there is no thumbnail image, just the filename. These are what I called 'ghosts'.

These are not necessarily Assets we are using right now, we're trying to build a library for future use. We make sure we click the Add to Library button.

There is nothing special about the images we are adding and no discernible pattern as to which get purged, except they all appear to be the most recently added (they're on the first 2 pages of our Assets)

Thanks again. I'll persevere and hopefully the issue will go away

Actually, I'm seeing this as well. What happens for me is that when I go back to look at the assets, a number of the asset records show the generic icon as the image thumbnail. Then when you open the asset record, the file area of the record is empty.

Let me know if I can be of any help troubleshooting.

That's EXACTLY what I'm seeing. Check the link in my earlier message. Same for you?

I added a new Asset yesterday and I'm waiting to see if it too disappears in what I understood from something written somewhere is a purge cycle.

I've had 2 lots of additions disappear in this way.

Yes. Exactly.

The images I lost were from a session where I uploaded maybe 20 assets, one after another.

From when I later re-added them (the next day, 2 days ago), they are still there.

So I wonder if it gets 'tired' when adding a bunch of images at once.

-- Monty

Yes, you have a point. All my disappearing assets were also added in a batch. I did about 50, all of which went walkabouts after a period. I just added a singleton yesterday and I'll check its status in a few hours. I'm not sure of the purge cycle.

Well, I can't see a pattern. Except that everything I added 30 hours ago has disappeared. I added singletons and they've gone. I then added a batch and they've all gone.

Drew/Rachel: can I turn off the asset purge function? This must surely be what is deleting newly added assets. They stick for a while, then go.

NO, I am NOT deleting manually. I haven't deleted anything after adding these now-disappeared Assets.

YES, I did click the add to library button

I should have added, what has disappeared is the image content itself. The asset name I assigned and a generic icon remain, but no images

Hi Stefan How did you add the assets from the new assets slide out feature? Or did you create a bucket and upload the assets via ftp? The reason I ask is that sometimes if I use the slide out asset feature to upload an asset it does not always seem to appear. I am sure its not an issue with the size of the file. Any assets added from the pages seems to upload without any issues. I did create a bucket and added files saved as library but these were originally loaded via the pages and all appear in the bucket and have remained in place. These assets have been reused. Also have you looked in the database to see if the assets are still named in the database?


We don't use buckets. We leave it at Default. We don't use FTP to add.

We use the Add Asset button, choose an image from the computer, go through the naming process, click to Add to library, hit Submit.

The added Assets go in fine, they can be used OK, but after 24 hours they're gone.

Not everything goes, we've got about 15 pages of Assets that were brought in by Perch when we did an upgrade (I don't remember which one) and which we renamed are still there and usable. But anything I add now will be gone tomorrow if the pattern persists. It can't be a coincidence that disappearing is more or less according to the purging cycle, surely?

I'll look in phpAdmin to see if the assets are still named, I assume they must be as the names of the disappeared still show up in the Assets window with a generic icon.

Stefan, even though the image is not showing and appears to be gone, add it to a perch record anyway. When I do that, the image is processed and attached. So it may be an issue that the thumbnail is getting cleared (and maybe as a result the imagename is not shown)

Let me know if it's the same for you.

Yes, good spot. I thought I tried that already to no effect, but I retried it just now.

It's exactly the same for me. The image is placed on the page though the thumbnail in the Assets panel shows a generic icon.

The image actually appears on the Add/Edit page once I put a Description in and before I hit Submit.

Interestingly the thumbnail then reappears in the Asset panel.

Yes, exactly!

So I suspect our thumbnails are not being protected as the rest of the asset record is when perch goes and does its (nightly?) purge of unused asset records.