Thread tagged as: Problem, Error

Error importing production db into local db

I've been running into an error each time I import my production db into my local dev server. I tried to delete all tables on my local computer but still run into error. Not sure how to get a copy now of a live db into my development environment.

Here is a link to a screenshot of the error message.

Could it be related to the custom share image in the details tab on a page, or the meta and social tab on blog posts for image when shared. Seem the error occurs on images in that field and not in the asset library, although I'm not sure what could cause this kind of error.

Here are my diagnostics from production server

    Perch Runway: 3.1.2, PHP: 7.0.32-0ubuntu0.16.04.1, MySQL: mysqlnd 5.0.12-dev - 20150407 - $Id: b5c5906d452ec590732a93b051f3827e02749b83 $, with PDO
    Server OS: Linux, apache2handler
    Installed apps: content (3.1.2), assets (3.1.2), categories (3.1.2), perch_blog (5.6.1), perch_forms (1.11), perch_kraken (1.1), chirp_seo (1.2.1), perch_mailchimp (3.1), perch_twitter (4.0)
    App runtimes: <?php $apps_list = array( 'perch_mailchimp', 'perch_forms', 'perch_twitter', 'perch_blog', 'pixelfix_shortcodes', );
    PERCH_PATH: /var/www/
    PERCH_CORE: /var/www/
    PERCH_RESFILEPATH: /var/www/
    Image manipulation: GD Imagick
    PHP limits: Max upload 128M, Max POST 128M, Memory: 256M, Total max file upload: 128M
    F1: 3b606135b33e6a102526838f4152a807
    Resource folder writeable: Yes
    DOCUMENT_ROOT: /var/www/
    REQUEST_URI: /perch/core/settings/diagnostics/
    SCRIPT_NAME: /perch/core/settings/diagnostics/index.php
Scott Gruber

Scott Gruber 0 points

  • 2 years ago
Rachel Andrew

Rachel Andrew 394 points
Perch Support

How are you importing this?

I'm using the Dropbox backup built into Perch Runway. I then import the sql into a mysql tool called Querious. In the past I've had no problems importing from a dropbox backup. I could try something else like phpmyadmin or Sequel Pro and will do soon. If that works I'll add to this thread.

After trying import several times I did go into the sql file and deleted the sql entry causing the error and another sql entry would also cause same error. Maybe something happened to corrupt that perch3_resources table, although I'm unsure. I haven't tried to repair database.

As far as I could tell, I didn't see these errors caused from images in the asset manager. I did try to delete meta images but that didn't fix issue.

Drew McLellan

Drew McLellan 2638 points
Perch Support

Why not try importing using Runway?

Oh my. That was easy and worked like a charm.

I just clicked restore button on the right above my plan, selected the backup file I wanted to use and import was done.

Reminds again why I love Perch Runway!

Thank you very much.

Yes, it is quite easy to execute and its simple to follow. Thanks for sharing the info with us. visit for hp product issues.