Thread tagged as: Error, Installation, Runway

'Sorry, that page could not be found.' after fresh Runway install

Hi, I have just installed Runway on a new server and all checked out during — went like a dream, uneventful — and I can access the control panel/dashboard, but when I access my site in-progress I get a 404 error. My .htaccess file at root level looks like this (I renamed 'Perch' as 'Admin'):

# Perch Runway
RewriteEngine On
RewriteCond %{REQUEST_URI} !^/admin 
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule .* /admin/core/runway/start.php [L] 

I haven't used Runway in over a year so I know I am rusty. This seems like a routing issue, maybe? I haven't done anything yet. My health check in settings is all good, diagnostics pasted below.

Perch Runway: 3.0.10, PHP: 7.1.9, MySQL: mysqlnd 5.0.12-dev - 20150407 - $Id: b396954eeb2d1d9ed7902b8bae237b287f21ad9e $, with PDO
Server OS: Linux, fpm-fcgi
Installed apps: content (3.0.10), assets (3.0.10), categories (3.0.10)
App runtimes: <?php $apps_list = [ ];
PERCH_PATH: /srv/users/serverpilot/apps/43-ranch/public/admin
PERCH_CORE: /srv/users/serverpilot/apps/43-ranch/public/admin/core
PERCH_RESFILEPATH: /srv/users/serverpilot/apps/43-ranch/public/admin/resources
Image manipulation: GD
PHP limits: Max upload 512M, Max POST 1024M, Memory: 256M, Total max file upload: 256M
F1: 3b606135b33e6a102526838f4152a807
Resource folder writeable: Yes
SCRIPT_NAME: /admin/core/settings/diagnostics/index.php
REQUEST_URI: /admin/core/settings/diagnostics/
DOCUMENT_ROOT: /srv/users/serverpilot/apps/43-ranch/public
Lindsay Masten

Lindsay Masten 0 points

  • 3 years ago

Where have you placed your master pages? Where is the page in your directory structure that your trying to view.

Ok. With a little poking around I see you have a test page at the root of the site which outputs “test”

From this I am guessing your adding the pages to the root of the site, which with a new site would not be the correct way using Runway. Your htaccess is setup for runway to use master pages which are placed in /admin/templates/pages.

If your going to place the files at root you will need to add to your htaccess file as below.

    # Perch Runway
    RewriteEngine On
    RewriteCond %{REQUEST_URI} !^/admin
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule .* /admin/core/runway/start.php [L]

Hi Robert,

Thanks for taking a look under the hood! That test page was actually my botched attempt to make sure I wasn't misremembering how master pages work... not how I'm hoping to set up the site. What happened was, I did the Runway install this afternoon and when I went to see what the frontend looked like post-install, I immediately hit a 404 error. (If that's expected behavior prior to setting up my own master pages, I totally forgot.) So I quickly threw in a test index.php just to make sure I wasn't missing anything.

I ended up going back and checking the last Runway site I built to see the setup and saw I did not need an index.php there, I just haven't gone back to work on the project on-server until just now, when I deleted that index.php at the root level.

Yes. The 404 is the expected behavior in your current setup until you add a page and select a master page as the template. If you place a file at root, then you will need the htaccess I posted otherwise you will continue to get 404.

Got it! And I don't even mind looking like a doofus.

I've been working with Craft and Vin65 for the past year and my brain just shelved the Perch knowledge base, apparently. Time to watch a video.