Thread tagged as: Problem

One of my templates is suddenly not working

I updated to 2.8.17

Immediately I was unable to add content to a region defined by this template, which has hitherto worked for several thousand pages

<perch:content id="text" type="textarea" label="Text" editor="redactor" html="true" imagewidth="760" before="This is the main story area" />

Any ideas? Diagnostic attached


Perch: 2.8.17 Production mode: Production (100) Installed apps: content (2.8.17), assets (2.8.17), categories (2.8.17), perch_gallery (2.8.4), perch_comments (1.0.1) DB driver: PDO DB tables: BattleofBritainRoll, BomberCommandCleaned, BomberCommandCleanedDF, BomberCommandCleanedDFBU, BomberCommandLosses, BomberCommandNew, BomberCommandOperationalLosses, BomberCommandTest, BomberCommandUpdateTest, DeutscheKreuzGoldAwards, DeutscheKreuzNew, KrackerDatabase, KrackerDatabase2, KrackerDatabase2BUOct15, KrackerDatabase2New, KrackerDatabase2NewBU2, KrackerDatabase2NewCopy, KrackerLatest, KrackerLatestNew, LuftwaffePilotData, PoWAlliedMaster, PolishHonourRoll_West, RAAFEuropeanLosses, RAAFLosses, RunnymedeMemorial, TopScorers, hesk_attachments, hesk_categories, hesk_kb_articles, hesk_kb_attachments, hesk_kb_categories, hesk_logins, hesk_mail, hesk_notes, hesk_online, hesk_pipe_loops, hesk_replies, hesk_std_replies, hesk_tickets, hesk_users, perch2_categories, perch2_category_counts, perch2_category_sets, perch2_content_index, perch2_content_items, perch2_content_regions, perch2_gallery_albums, perch2_gallery_image_versions, perch2_gallery_images, perch2_navigation, perch2_navigation_pages, perch2_page_templates, perch2_pages, perch2_resource_log, perch2_resource_tags, perch2_resources, perch2_resources_to_tags, perch2_settings, perch2_user_privileges, perch2_user_role_privileges, perch2_user_roles, perch2_users Users: 9 App runtimes: <?php include(PERCH_PATH.'/core/apps/content/runtime.php'); include(PERCH_PATH.'/addons/apps/perch_comments/runtime.php'); include(PERCH_PATH.'/addons/apps/perch_gallery/runtime.php'); ?> Editor plug-ins: redactor, tinymce, markitup, ckeditor H1: 8d4b0a628e60863b3691edb8330b1ecb L1: 30e62d05c451dbc35ba141aa8669341b headerColour: #ffffff content_singlePageEdit: 1 helpURL: siteURL: / hideBranding: 1 content_collapseList: 1 lang: en-gb latest_version: 2.8.15 headerScheme: light dashboard: 0 content_hideNonEditableRegions: 0 logoPath: /editorial/resources/1356354991_arbanner235Perch.png on_sale_version: 2.8.17 update_2.4.2: done content_frontend_edit: 1 update_2.4.3: done update_2.4.4: done update_2.4.5: done update_2.4.9: done perch_gallery_update: 2.8.4 update_2.5.1: done update_2.5.2: done update_2.5.3: done update_2.5.4: done update_2.6: done update_2.6.3: done update_2.6.5: done update_2.6.6: done update_2.7.2: done update_2.7.10: done update_2.8.2: done update_2.8.6: done update_2.8.17: done PERCH_DEVELOPMENT: 10 PERCH_STAGING: 50 PERCH_PRODUCTION: 100 PERCH_DB_USERNAME: kelstef_arem PERCH_DB_SERVER: localhost PERCH_DB_DATABASE: kelstef_arem PERCH_DB_PREFIX: perch2_ PERCH_EMAIL_FROM: PERCH_EMAIL_FROM_NAME: Stefan Youngs PERCH_LOGINPATH: /editorial PERCH_PATH: /home4/kelstef/public_html/editorial PERCH_CORE: /home4/kelstef/public_html/editorial/core PERCH_RESFILEPATH: /home4/kelstef/public_html/editorial/resources PERCH_RESPATH: /editorial/resources PERCH_HTML5: 1 PERCH_CLEAN_RESOURCES: PERCH_RUNWAY: PERCH_ERROR_MODE: DIE PERCH_DATE_LONG: %d %B %Y PERCH_DATE_SHORT: %d %b %Y PERCH_TIME_SHORT: %H:%M PERCH_TIME_LONG: %H:%M:%S PERCH_DEBUG: PERCH_PREVIEW_ARG: preview PERCH_TEMPLATE_PATH: /home4/kelstef/public_html/editorial/templates PERCH_DEFAULT_DOC: index.php PERCH_DEFAULT_EXT: .php PERCH_PRODUCTION_MODE: 100 PERCH_RWD: PERCH_HTML_ENTITIES: PERCH_SSL: PERCH_STRIPSLASHES: PERCH_PROGRESSIVE_FLUSH: 1 PERCH_AUTH_PLUGIN: PERCH_DB_CHARSET: utf8 PERCH_DB_PORT: PERCH_DB_SOCKET: PERCH_SESSION_TIMEOUT_MINS: 20 HOSTING SETTINGS

PHP: 5.4.45 Zend: 2.4.0 OS: Linux SAPI: cgi-fcgi Safe mode: not detected MySQL client: 5.5.42-37.1 MySQL server: 5.5.42-37.1 Extensions: Core, date, ereg, libxml, openssl, pcre, sqlite3, zlib, bcmath, bz2, calendar, ctype, curl, dom, hash, fileinfo, filter, ftp, gd, gettext, gmp, SPL, iconv, session, intl, json, mbstring, mcrypt, mssql, mysql, mysqli, odbc, standard, PDO, pdo_mysql, pdo_sqlite, Phar, posix, pspell, Reflection, imap, SimpleXML, soap, sockets, exif, tidy, tokenizer, wddx, xml, xmlreader, xmlrpc, xmlwriter, xsl, zip, cgi-fcgi, imagick, SourceGuardian, mhash, ionCube Loader, Zend Guard Loader GD: Yes ImageMagick: Yes PHP max upload size: 64M PHP max form post size: 64M PHP memory limit: 256M Total max uploadable file size: 64M Resource folder writeable: Yes Session timeout: 24 minutes Native JSON: Yes Filter functions: Yes Transliteration functions: Yes DOCUMENT_ROOT: /home4/kelstef/public_html GATEWAY_INTERFACE: CGI/1.1 HTTP_ACCEPT: text/html,application/xhtml+xml,application/xml;q=0.9,/;q=0.8 HTTP_ACCEPT_ENCODING: gzip, deflate HTTP_ACCEPT_LANGUAGE: en-us HTTP_CONNECTION: close HTTP_COOKIE: PHPSESSID=b7496d97a804b50e4645b2c2583218b9; cmsa=1; __unam=7639673-1497afb6b28-6063fd13-6436; __utma=109100309.1852979748.1415107534.1424778748.1425332764.101; _ga=GA1.2.1852979748.1415107534; _hp2_id.3226262449=6659994950585736.1407298370.0822836058 HTTP_DNT: 1 HTTP_HOST: HTTP_REFERER: HTTP_USER_AGENT: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_1) AppleWebKit/601.2.7 (KHTML, like Gecko) Version/9.0.1 Safari/601.2.7 HTTP_X_HTTP_PROTO: HTTP/1.1 HTTP_X_LOG_7528: HTTP_X_REAL_IP: PATH: /bin:/usr/bin PHPRC: /opt/php54/lib QUERY_STRING: extended REDIRECT_STATUS: 200 REMOTE_ADDR: REMOTE_PORT: 28028 REQUEST_METHOD: GET REQUEST_URI: /editorial/core/settings/diagnostics/?extended SCRIPT_FILENAME: /home4/kelstef/public_html/editorial/core/settings/diagnostics/index.php SCRIPT_NAME: /editorial/core/settings/diagnostics/index.php SERVER_ADDR: SERVER_ADMIN: SERVER_NAME: SERVER_PORT: 80 SERVER_PROTOCOL: HTTP/1.1 SERVER_SIGNATURE: <address>Apache Server at Port 80</address> SERVER_SOFTWARE: Apache UNIQUE_ID: Vld0dTJXkIEAAEo@HvMAAAEq PHP_SELF: /editorial/core/settings/diagnostics/index.php REQUEST_TIME_FLOAT: 1448572021.57 REQUEST_TIME: 1448572021 argc: 1

Stefan Youngs

Stefan Youngs 0 points

  • 5 years ago
Drew McLellan

Drew McLellan 2638 points
Perch Support

Which version were you updating from?

Other than the before attribute not meaning anything, that tag looks ok. How is it failing?

Updated from 2.8.6

If I select the region and add text, when I click Submit the text disappears and is not on the published page

Text entered into a region called Headline and defined as follows works OK

<perch:content id="text" type="text" label="Text" html="true" required="true" title="true" />

(The 'before' attribute was a much earlier attempt at something, which didn't work. I left it in by mistake.

I stress this template was working fine in 2.8.6.

if i revert to 2.8.6, can I simple delete the core folder from 2.8.17 and reinstall the core folder from 2.8.6?

The only change I made was to apply your MarkIt patch prior to updating to 2.8.17. I left that. patch in place before applying the 2.8.17 update

Drew McLellan

Drew McLellan 2638 points
Perch Support

There's not been any change between those versions that should affect this. The tag looks ok.

Do you get any errors logged?

No errors logged. I enter the text, click Submit and it's gone.

One of our editors is experiencing the same so it's not related to my Mac

Drew McLellan

Drew McLellan 2638 points
Perch Support

Is that all that's in the template?

Yes, that is all that is in the template for the region defined as Story, which is the one where the text doesn't appear

I've used the same template for a second region on the same page called AuthDate and this too has the disappearing text issue.

The Headline template however, as I said, continues to work correctly as it did before, and a Picture template on the same page also works correctly

If I switch the region to a template NOT using Redactor (TinyMCE for example) then everything works. This template works fine

<perch:content id="text" type="textarea" label="Text" editor="tinymce" html="true" imagewidth="760" imageheight="570" before="This is the main story area" />

By the way, thanks for being up so late and responding.

I'm using Redactor v8.2.1

Drew McLellan

Drew McLellan 2638 points
Perch Support

If you keep the same template, but switch it to use tinymce rather than redactor, does that have any impact?

Yes, if I use the same template, but replace editor="redactor" with editor="tinymce", then everything works fine

Drew McLellan

Drew McLellan 2638 points
Perch Support

Is redactor working in other places? This is looking increasingly like a redactor-related issue.

I have another region in the same Master Page that also has editor=" redactor" and that too does not work.

Is it safe for me to drop back to 2.8.6, which was working fine immediately prior to my adding the MarkItUp patch? Unfortunately I didn't test 2,8,6 before immediately upgrading to 2.8.17 so I don't know if the issue had arisen prior to the upgrade to 2.8.17. In other words, is it a conflict between the patch and Redactor or between 2.8.17 and Redactor?

We have Editors around the world familiar with the way Redactor works and I would be reluctant to switch to TinyMCE

Drew McLellan

Drew McLellan 2638 points
Perch Support

Have you updated Redactor to the latest?

Do you get any errors in the browser console?

Updating to the latest Redactor appears to have solved the problem. Thanks for your patience.

I haven't fully tested this yet so I may have to come back to you if I get problems, but so far, looking good.

Thanks again