Thread tagged as: Problem, Configuration, Runway

Runway upgrade

Good afternoon,

I'm trying to update a client site to Runway locally and I've followed the docs but nothing seems to happen. I've changed the core folder, checked my apps list and ensured the correct .htaccess rules (and the runway.php file) is in place. Unfortunately nothing at all happens - I can still run the site locally, nothing is broken and the admin panel works fine but it's just standard Perch - not Runway. I've also tried to run this script:


This runs fine and says that I'm up to date but nothing has happened...I was running Perch 3.1.3 (the site has been running Perch since version 2, so has that database structure) and I'm upgrading to Runway 3.1.3. As far as I can tell the only thing I haven't done is change the licence key but I wasn't ready to upgrade the live site so was waiting on that. Diagnostics below:

Perch: 3.1.3, PHP: 7.1.20, MySQL: mysqlnd 5.0.12-dev - 20150407 - $Id: 38fea24f2847fa7519001be390c98ae0acafe387 $, with PDO
Server OS: Darwin, cgi-fcgi
Installed apps: content (3.1.3), assets (3.1.3), categories (3.1.3), perch_blog (5.6.1), perch_forms (1.12), root_heartbeat (1.0.1), redfinch_optim (1.0), perch_mailchimp (3.1)
App runtimes: <?php $apps_list = array( 'perch_blog', 'perch_forms', 'perch_mailchimp' );
PERCH_PATH: /Users/lea/Repositories/Amberol/Amberol-Core-Site/build/admin
PERCH_CORE: /Users/lea/Repositories/Amberol/Amberol-Core-Site/build/admin/core
PERCH_RESFILEPATH: /Users/lea/Repositories/Amberol/Amberol-Core-Site/build/admin/resources
Image manipulation: GD
PHP limits: Max upload 32M, Max POST 32M, Memory: 128M, Total max file upload: 32M
F1: 3b606135b33e6a102526838f4152a807
Resource folder writeable: Yes
SCRIPT_NAME: /admin/core/settings/diagnostics/index.php
REQUEST_URI: /admin/core/settings/diagnostics/
DOCUMENT_ROOT: /Users/lea/Repositories/Amberol/Amberol-Core-Site/build
HTTP_HOST: amberol.local

I'm a bit lost?!

Thanks in advance, Lea.

Lea Chapman

Lea Chapman 0 points

  • 2 years ago
Drew McLellan

Drew McLellan 2638 points
Perch Support

Perch: 3.1.3

You're still running Perch there.

Thanks - I know that but I've followed all the upgrade steps including replacing core with Perch Runway core and nothing happens (as per my post). I've asked someone else to have a go too and they get the same result.

Appears this was all down to the licence key. All solved now.


root_heartbeat app ??

Eagle eyed comment there :)

That's actually an old app we developed in-house that we don't tend to use any more - we wrote something to 'phone home' and tell us the Perch version numbers of sites we develop so we can keep on top of updates but we've found that most customers are getting us to keep on top of things as a part of the contract now so don't tend to need it.

That was/is a clever idea... I kinda expected it might be such... as the "heartbeat" had me wondering what the app was tracking.

Thanks... and glad you got the license thing sorted.